HDU1251 统计难题 (字典树模板题)

                                统计难题

Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).

Input

输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.

Output

对于每个提问,给出以该字符串为前缀的单词的数量.

Sample Input

banana
band
bee
absolute
acm

ba
b
band
abc

Sample Output

2
3
1
0
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
	int   num;
	struct node *next[26];
};
struct node root;
void creat(char *str)
{
	int len=strlen(str);
	int i;
	struct node *p,*q;
	p=&root;
	for(i=0;i<len;i++)
	{
		int t=str[i]-'a';
		if(p->next[t]==NULL)
		{
			q=(struct node*)malloc(sizeof(struct node));
			q->num =1;
            for(int j=0;j<26;j++)
	        q->next[j]=NULL;
            p->next[t]=q;
            p=p->next[t];
		}
		else
		{
			p->next[t]->num++;
			p=p->next[t];
		}
	}
}
int find(char *str)
{
	int i;
	int len=strlen(str);
	struct node *q=&root;
	for(i=0;i<len;i++)
	{
		int t=str[i]-'a';
		q=q->next[t];
		if(q==NULL)
		return  0;
	}
	return q->num;
}
int main()
{
	char str[20],st[20];
	int i;
	for( i=0;i<26;i++)
	root.next[i]=NULL;
	while(gets(str)&&str[0]!='\0')
	{
	creat(str);
	}
	while(scanf("%s",st)!=EOF)
	{
		int count=find(st);
		printf("%d\n",count);
	}
	return  0;
}

猜你喜欢

转载自blog.csdn.net/qq_45302622/article/details/105128804