POJ - 2393 Yogurt factory

问题描述:

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky’s factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt’s warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky’s demand for that week.

输入说明:

  • Line 1: Two space-separated integers, N and S.

  • Lines 2…N+1: Line i+1 contains two space-separated integers: C_i and Y_i.

输出说明:

  • Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.

SAMPLE INPUT:

4 5
88 200
89 400
97 300
91 500

SAMPLEOUTPUT:

126900

hints:

In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.

思路:

题意,每周我们需要交付一定量的酸奶,但是可以生产无限量的酸奶,储存酸奶需要花费一定的费用,每周生产的cost都是不一样的,我们应该如何生产能够让成本最少。一道很经典的贪心问题,首先第一周至少要生产所需要的量,其次,如果前一周要生产之后的酸奶,需要比较的是当周的生产费用+储存费用与下周的生产费用的大小关系。因此在处理时,依次输入n周的生产所需和所需的酸奶量,用一个变量储存当前最划算的生产方式,每周都进行比较,如果之前某周的生产更划算,就在那一周多生产当前周所需的酸奶数,反之更新变量的储存然后按照当前周的计划进行生产。

AC代码:


#include<iostream>
using namespace std;
int main()
{
    
    
    int n,s,c=0,ci,yi;
    long long ans=0;
    cin>>n>>s;
    for(int i=1;i<=n;i++)
    {
    
    
        cin>>ci>>yi;
        if(i==1)
        {
    
    
            ans+=ci*yi;
            c=ci+s;
        }
        else
        {
    
    
            if (c>ci)
            {
    
    
                ci=ci;
            }
            else
            {
    
    
                ci=c;
            }
            ans+=ci*yi;
            c=ci+s;
        }
    }
    cout<<ans<<endl;
    return 0;
}


猜你喜欢

转载自blog.csdn.net/m0_51727949/article/details/114930064