LIS 最长上升子序列和

最长上升子序列 or 最长公共子序列见以往博客
以hdu 1087 Super Jumping! Jumping! Jumping!
为例:

题目:

Problem Description
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input
Input contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.

Output
For each case, print the maximum according to rules, and one line one case.

Sample Input
3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output
4
10
3

题意:

就是给你任意组数每组n个数,n为0的时候结束程序。然后给你n个value(价值) 让你求最长上升子序列和 如 1 3 2则答案为 1+ 3

思路:

dp 求上升子序列的和 再枚举找最大

代码or模板:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>

using namespace std;
const int N=1e5+10;
int a[N],dp[N];

int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin>>n&&n)
    {
        memset(a,0,sizeof(a));
        memset(dp,0,sizeof(dp));
        for(int i=1; i<=n; i++)
            cin>>a[i],dp[i]=a[i];//将dp数组初始化为a数组
        int ans=-N;

        for(int i=n-1; i>=1; i--)
        {
            ans=0;  //这里一定要让ans为0 如果和为负数 就处理为0了
            for(int j=i+1; j<=n; j++)
            {
                if(a[j]>a[i])//判断是否是上升的
                    ans=max(ans,dp[j]);
            }
            dp[i]+=ans;//更新dp的值
        }
        ans=-N;
        for(int i=1; i<=n; i++)  //找上升子序列的最大和
        {
            ans=max(dp[i],ans);
        }
        cout<<ans<<endl;

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Puppet__/article/details/79338584