L3-016 二叉搜索树的结构 (30分)

二叉搜索树或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值;若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值;它的左、右子树也分别为二叉搜索树。(摘自百度百科)

给定一系列互不相等的整数,将它们顺次插入一棵初始为空的二叉搜索树,然后对结果树的结构进行描述。你需要能判断给定的描述是否正确。例如将{ 2 4 1 3 0 }插入后,得到一棵二叉搜索树,则陈述句如“2是树的根”、“1和4是兄弟结点”、“3和0在同一层上”(指自顶向下的深度相同)、“2是4的双亲结点”、“3是4的左孩子”都是正确的;而“4是2的左孩子”、“1和3是兄弟结点”都是不正确的。

输入格式:
输入在第一行给出一个正整数N(≤100),随后一行给出N个互不相同的整数,数字间以空格分隔,要求将之顺次插入一棵初始为空的二叉搜索树。之后给出一个正整数M(≤100),随后M行,每行给出一句待判断的陈述句。陈述句有以下6种:

A is the root,即"A是树的根";
A and B are siblings,即"A和B是兄弟结点";
A is the parent of B,即"A是B的双亲结点";
A is the left child of B,即"A是B的左孩子";
A is the right child of B,即"A是B的右孩子";
A and B are on the same level,即"A和B在同一层上"。
题目保证所有给定的整数都在整型范围内。

输出格式:
对每句陈述,如果正确则输出Yes,否则输出No,每句占一行。

输入样例:
5
2 4 1 3 0
8
2 is the root
1 and 4 are siblings
3 and 0 are on the same level
2 is the parent of 4
3 is the left child of 4
1 is the right child of 2
4 and 0 are on the same level
100 is the right child of 3
输出样例:
Yes
Yes
Yes
Yes
Yes
No
No
No
会爆空间的,直接用一维存就好

#include<bits/stdc++.h>
using namespace std;
#define ll long long
int n,t,tt,root;
map<int,int>l,r,fa,depth,b;
string s; 
void inser(int x,int v,int dep)
{
    
    
	if(v<x)
	{
    
    
		if(l[x]==-1) 
		 fa[v]=x,l[x]=v,depth[v]=dep;
		else inser(l[x],v,dep+1);
	}
	else
	{
    
    
		if(r[x]==-1) 
		 fa[v]=x,depth[v]=dep,r[x]=v;
		else inser(r[x],v,dep+1);
	}
}
int main()
{
    
    
 ios::sync_with_stdio(false);
 cin>>n;
 cin>>root;
 fa[root]=-1;b[root]=1;l[root]=-1;r[root]=-1;
 for(int i=2;i<=n;i++)
 {
    
    
 	cin>>t;
 	inser(root,t,1);
 	b[t]=1;l[t]=-1;r[t]=-1;
 }
 //for(int i=0;i<=4;i++)
 // cout<<l[i]<<" "<<r[i]<<" "<<fa[i]<<" "<<depth[i]<<endl;
 cin>>n;
 while(n--)
 {
    
    
 	cin>>t>>s;
 	if(s=="is")
 	{
    
    
 	  cin>>s>>s;
	  if(s=="root")
	  {
    
    
	  	if(t==root&&b[t]) cout<<"Yes";
	  	else cout<<"No";
	  }
	  else if(s=="parent")
	  {
    
    
	  	cin>>s>>tt;
	  	if(b[t]&&b[tt]&&(l[t]==tt||r[t]==tt)) cout<<"Yes";
	  	else cout<<"No";
	  }
	  else if(s=="left")
	  {
    
    
	  	cin>>s>>s>>tt;
	  	if(b[t]&&b[tt]&&l[tt]==t) cout<<"Yes";
	  	else cout<<"No";
	  }
	  else if(s=="right")
	  {
    
    
	  	cin>>s>>s>>tt;
	  	if(b[t]&&b[tt]&&r[tt]==t) cout<<"Yes";
	  	else cout<<"No";
	  }	
	}
	else if(s=="and")
	{
    
    
		cin>>tt;
		cin>>s>>s;
		if(s=="on")
		{
    
    
		 cin>>s>>s>>s;
		 if(b[t]&&b[tt]&&depth[t]==depth[tt]) cout<<"Yes";
		 else cout<<"No";	
		}
		else
		{
    
    
			if(b[t]&&b[tt]&&fa[t]==fa[tt]) cout<<"Yes";
			else cout<<"No";
		}
	}
	cout<<endl;
 }
 return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43540515/article/details/110258610