1.8 23:二维数组回形遍历

描述
给定一个row行col列的整数数组array,要求从array[0][0]元素开始,按回形从外向内顺时针顺序遍历整个数组。如图所示:

在这里插入图片描述
输入
输入的第一行上有两个整数,依次为row和col。
余下有row行,每行包含col个整数,构成一个二维整数数组。
(注:输入的row和col保证0 < row < 100, 0 < col < 100)
输出
按遍历顺序输出每个整数。每个整数占一行。
样例输入
4 4
1 2 3 4
12 13 14 5
11 16 15 6
10 9 8 7
样例输出
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16

#include <iostream>
using namespace std;
#define MAX 101
int main()
{
    
    
	int col,row,a[MAX][MAX],count,k,i,j;
	cin>>row>>col;
	for(i=0;i<row;i++)
	{
    
    
		for(j=0;j<col;j++)
		{
    
    
			scanf("%d", &a[i][j]);
		}		
	}
	if(row==1)
	{
    
    
		i=0;
		j=0;
		for(j;j<col;j++)
		{
    
    
			cout<<a[i][j]<<endl;
		}
	}else if(col==1)
	{
    
    
		i=0;
		j=0;
		for(i;i<row;i++)
		{
    
    
			cout<<a[i][j]<<endl;
		}
	}else
	{
    
    
		i=0;
		j=0;
		count = col*row;
		while(count>0)
		{
    
    
			
			for(k=1;k<col;k++)
			{
    
    
				cout<<a[i][j++]<<endl;
				count--;
			}
			for(k=1;k<row;k++)
			{
    
    
				cout<<a[i++][j]<<endl;
				count--;
			}
			for(k=1;k<col;k++)
			{
    
    
				cout<<a[i][j--]<<endl;
				count--;
			}
			for(k=1;k<row;k++)
			{
    
    
				cout<<a[i--][j]<<endl;
				count--;
			}
			row -= 2;
			col -= 2;
			i++;
			j++;
			if(row==1)
			{
    
    
				for(k=1;k<=col;k++)
				{
    
    
					cout<<a[i][j++]<<endl;
					count--;
				}
			} else if(col==1)
			{
    
    
				for(k=1;k<=row;k++)
				{
    
    
					cout<<a[i++][j]<<endl;
					count--;
				}
			}
		}
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yansuifeng1126/article/details/111637212
1.8