细节-A Bug‘s Life

总时间限制: 10000ms

内存限制: 65536kB

描述

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

输入

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

输出

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

样例输入

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

样例输出

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;

const int MAXN = 2005;
int parent[MAXN];
int relation[MAXN];

/*
relation
0 same
1 different 
 */

int get_root(int i) {
    if (i == parent[i])
        return i;

    int rt = get_root(parent[i]);
    relation[i] = (relation[i] + relation[parent[i]]) % 2;
    parent[i] = rt;
    return rt;
}

int main()
{
    int t;
    scanf("%d", &t);
    for (int kase = 1; kase <= t; ++kase) {
        int n, k;
        scanf("%d%d", &n, &k);
        memset(relation, 0, sizeof(relation));
        for (int i = 1; i <= n; ++i)
            parent[i] = i;

        bool ok = 1;
        for (int i = 0; i < k; ++i) {
            int x, y;
            scanf("%d%d", &x, &y);

            if (!ok)
                continue;
            
            int rx = get_root(x);
            int ry = get_root(y);

            if (rx == ry) {
                if (relation[x] == relation[y])
                    ok = 0;
            }
            else {
                int r = (relation[x] + relation[y] + 1) % 2;
                parent[rx] = ry;
                relation[rx] = r;
            }
        }

        printf("Scenario #%d:\n", kase);
        if (!ok)
            printf("Suspicious bugs found!\n");
        else
            printf("No suspicious bugs found!\n");
        printf("\n");
    }

    return 0;
}

这道题不用再做了,会了“食物链”那道这题也就会了

扫描二维码关注公众号,回复: 12274742 查看本文章

【细节】

注意,不能直接break出去,因为输入还没有完成!!

猜你喜欢

转载自blog.csdn.net/w112348/article/details/108948996