7-5 重排链表

给定一个单链表 L​1​​→L​2​​→⋯→L​n−1​​→L​n​​,请编写程序将链表重新排列为 L​n​​→L​1​​→L​n−1​​→L​2​​→⋯。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。

输入格式:

每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (≤10​5​​)。结点的地址是5位非负整数,NULL地址用−1表示。
接下来有N行,每行格式为:
Address Data Next
其中Address是结点地址;Data是该结点保存的数据,为不超过10​5​​的正整数;Next是下一结点的地址。题目保证给出的链表上至少有两个结点。

输出格式:

对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。

输入样例:

00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

输出样例:

68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1

思路清晰,我是钻一
AC代码:

#include<bits/stdc++.h>
using namespace std;
int data[100000],link[100000];
vector<int> add,result;//先串起来存入add
int main() 
{
    
    
 	int root,n,temp,id,next;
 	cin>>root>>n;
 	for (int i = 0;i < n; i++) 
 	{
    
    
  		cin >> temp >> id >> next;
  		link[temp] = next;
  		data[temp] = id;     
 	}
 	for (int i = root;i != -1;i = link[i])
  		add.push_back(i);
 	int first = 0,last = add.size()-1;
 	while (first <= last)
 	{
    
    
  		if (first <= last)
  			 result.push_back(add[last--]);
  		if (first <= last)
   			result.push_back(add[first++]);
 	}
 	for (int i = 0; i < result.size()-1; i++)
  		printf("%05d %d %05d\n", result[i], data[result[i]], result[i + 1]);
 	printf("%05d %d %d\n", result[result.size() - 1], data[result[result.size() - 1]],-1);
 	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_45989486/article/details/108540835
7-5