二维数组:蛇形填空

蛇形填空

【题目描述】
在 n * n 方陈里填入1,2,…,n*n,要求填成蛇形。例如n=4时方陈为:

10 11 12 1 
9 16 13 2 
8 15 14 3 
7 6 5 4 

【输入】
直接输入方陈的维数,即n的值。(n<=100)

【输出】
输出结果是蛇形方陈。
【样例输入】
3
【样例输出】
7 8 1
6 9 2
5 4 3

【代码】

#include <iostream>
using namespace std;

int a[101][101];

int main()
{
    
    
    int n,x,y,tot;
    
    cin>>n;
    tot=a[x=0][y=n-1]=1;
    
    while (tot<n*n)
    {
    
    
        while (x+1<n && !a[x+1][y])//向下 
            a[++x][y]=++tot;
        while (y-1>=0 && !a[x][y-1])//向左 
            a[x][--y]=++tot;
        while (x-1>=0 && !a[x-1][y])//向上 
            a[--x][y]=++tot;
        while (y+1<n && !a[x][y+1])//向右 
            a[x][++y]=++tot;
    }
    
    for (x=0; x<n; x++){
    
    
        for (y=0 ;y<n; y++)
       		cout << a[x][y] << " ";
        cout<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_44524918/article/details/109168810