Network(POJ-1861)

POJ - 1861 传送门

Description

Andrew is working as system administrator and is planning to establish a new network in his company.
There will be N hubs in the company, they can be connected to each other using cables. Since each worker of the company must have access to the whole network, each hub must be accessible by cables from any other hub (with possibly some intermediate hubs).
Since cables of different types are available and shorter ones are cheaper, it is necessary to make such a plan of hub connection, that the maximum length of a single cable is minimal. There is another problem — not each hub can be connected to any other one because of compatibility problems and building geometry limitations. Of course, Andrew will provide you all necessary information about possible hub connections.
You are to help Andrew to find the way to connect hubs so that all above conditions are satisfied.

Input

The first line of the input contains two integer numbers: N - the number of hubs in the network (2 <= N <= 1000) and M - the number of possible hub connections (1 <= M <= 15000).
All hubs are numbered from 1 to N. The following M lines contain information about possible connections - the numbers of two hubs, which can be connected and the cable length required to connect them. Length is a positive integer number that does not exceed 106. There will be no more than one way to connect two hubs. A hub cannot be connected to itself. There will always be at least one way to connect all hubs.

Output

Output first the maximum length of a single cable in your hub connection plan (the value you should minimize). Then output your plan: first output P - the number of cables used, then output P pairs of integer numbers - numbers of hubs connected by the corresponding cable. Separate numbers by spaces and/or line breaks.

Sample Input

4 6
1 2 1
1 3 1
1 4 2
2 3 1
3 4 1
2 4 1

Sample Output

1
4
1 2
1 3
2 3
3 4


题目大意

给定一个图,n个顶点,m条边,让我们使图连通且边权值和最小
要我们输出最大边边权的最小值,以及边的总数,还要我们把得到的新图打印出来

解题思路

Kruskal:
把边权从小到大排列,然后判断左右两个点是否在一个集合(已经连通)里面,若在则不管它,不在就合并一下从而得到一条新边,并且得到这条新边的权值
并查集 + Kruskal 就可以解决


AC代码

#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 15100;
const int inf = -999;
int n,m;
int fa[maxn];
int Cnt = 0;
int maxVal = inf;
struct node
{
	int from;
	int to;
	int val;
}Edge[maxn],newEdge[maxn];
bool cmp(node a, node b)
{
	return a.val < b.val;
}
void init()
{
	for(int i = 1 ; i < maxn ; i++)
	{
		fa[i] = i;
	}
}
int Find(int x)
{
	return fa[x] == x? x: fa[x] = Find(fa[x]);
}
void unite(int x ,int y)
{
	fa[Find(x)] = Find(y); 
}
void Kruskal()
{
	for(int i = 1 ; i <= m ; i++)
	{
		int a = Find(Edge[i].from);
		int b = Find(Edge[i].to);
		if(a != b)
		{
			unite(a,b);
			//获得新边并保存,Cnt记录当前边数
			Cnt++;
			newEdge[Cnt].from = Edge[i].from;
			newEdge[Cnt].to = Edge[i].to;
			newEdge[Cnt].val = Edge[i].val;	
			//更新最大边权	
			if(maxVal < Edge[i].val)
			{	
				maxVal = Edge[i].val;
			}
		}
	}
}
void PrintAns()
{
	cout<<maxVal<<endl;
	cout<<Cnt<<endl;
	for(int i = 1 ; i <= Cnt ; i++)
	{
		cout<<newEdge[i].from<<" "<<newEdge[i].to<<endl;
	}
}
int main()
{
	ios::sync_with_stdio(false),cin.tie(0),cout.tie(0);
	cin>>n>>m;
	init();
	for(int i = 1 ; i <= m ; i++)
	{
		cin>>Edge[i].from>>Edge[i].to>>Edge[i].val;
	}
	sort(Edge+1,Edge+m+1,cmp);
	Kruskal();
	PrintAns();
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_46425926/article/details/107650081
今日推荐