UVa 714 Copying Books

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had
to be re-written by hand by so called scribers. The scriber had been given a book and after several
months he finished its copy. One of the most famous scribers lived in the 15th century and his name
was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and
boring. And the only way to speed it up was to hire more scribers.
Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The
scripts of these plays were divided into many books and actors needed more copies of them, of course.
So they hired many scribers to make copies of these books. Imagine you have m books (numbered
1, 2, . . . , m) that may have different number of pages (p1, p2, . . . , pm) and you want to make one copy of
each of them. Your task is to divide these books among k scribes, k ≤ m. Each book can be assigned
to a single scriber only, and every scriber must get a continuous sequence of books. That means, there
exists an increasing succession of numbers 0 = b0 < b1 < b2, . . . < bk−1 ≤ bk = m such that i-th scriber
gets a sequence of books with numbers between bi−1 + 1 and bi
. The time needed to make a copy of
all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to
minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal
assignment.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow
the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k,
1 ≤ k ≤ m ≤ 500. At the second line, there are integers p1, p2, . . . , pm separated by spaces. All these
values are positive and less than 10000000.
Output
For each case, print exactly one line. The line must contain the input succession p1, p2, . . . pm divided
into exactly k parts such that the maximum sum of a single part should be as small as possible. Use
the slash character (‘/’) to separate the parts. There must be exactly one space character between any
two successive numbers and between the number and the slash.
If there is more than one solution, print the one that minimizes the work assigned to the first scriber,
then to the second scriber etc. But each scriber must be assigned at least one book.
Sample Input
2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100
Sample Output
100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

今天也是好久没有做题了,今天晚上随便找了一个题
题意:有书需要被复印,连续m本需要划分给分给k个人进行复印,让每个人被分配的书的总页数的最大值最小,保证每个人至少被分配一本书。

题解:二分+贪心,先用二分把分配的总页数的最大值的最小值求出,然后用贪心从后往前划分,因为要求前面的人尽量工作量少。

#include <iostream>
#include <cstring>
#include <cstdio>
#define Maxn 505
#define  LL long long
using namespace std;
int m,k;
LL p[Maxn],Sum,Min,Ans;
bool vis[Maxn];

inline int Judge(LL Tenp) {
    memset(vis,0,sizeof(vis));
    int cnt = 0,pos = m - 1;
    while(pos >= 0) {
        LL sum = 0;
        bool ok = true;
        while(pos >= 0 && sum + p[pos] <= Tenp) {
            ok = false;
            sum += p[pos];
            --pos;
        }
        if(ok) return k + 1;
        if(pos >= 0) vis[pos] = true;
        ++cnt;
    }
    return cnt;
}

int Binary() {
    LL l = Min,r = Sum,Mid;
    while(l < r) {
        Mid = l + r >> 1;
        if(Judge(Mid) <= k) r = Mid;
        else l = Mid + 1;
    }
    return r;
}

void Print() {
    int cnt = Judge(Ans);
    for(int i=0; i<m-1 && cnt<k; i++) if(!vis[i]){
        vis[i] = true;
        ++cnt;
    }
    for(int i=0; i<m; i++) {
        if(i) printf(" %lld",p[i]);
        else printf("%lld",p[i]);
        if(vis[i]) printf(" /");
    }
    puts("");
}

int main(int argc,char* argv[]) {
    int T; scanf("%d",&T);
    while(T--) {
        scanf("%d %d",&m,&k);
        Sum = 0; Min = 0;
        for(int i=0; i<m; i++) {
            scanf("%d",&p[i]);
            Sum += p[i];
            Min = max(Min,p[i]);
        }

        Ans = Binary();
        Print();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_35776409/article/details/106306920