蓝桥杯——基础练习 数列特征

问题描述

给出n个数,找出这n个数的最大值,最小值,和。

输入格式

第一行为整数n,表示数的个数。

第二行有n个数,为给定的n个数,每个数的绝对值都小于10000。

输出格式

输出三行,每行一个整数。第一行表示这些数中的最大值,第二行表示这些数中的最小值,第三行表示这些数的和。

样例输入

5
1 3 -2 4 5

样例输出

5
-2
11

数据规模与约定

1 <= n <= 10000。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int main()
{
	int Max,Min,n,sum=0,x;
	cin >>n;
	cin >>x;
	Max=x;
	Min=x;
	sum=x;
	for(int i=1;i<n;i++){
		cin >>x;
		sum+=x;
		Max=max(Max,x);
		Min=min(Min,x);
	}
	cout <<Max<<endl;
	cout <<Min<<endl;
	cout <<sum<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_44888152/article/details/106738617
今日推荐