HDU_oj2000题

Problem Description

输入三个字符后,按各字符的ASCII码从小到大的顺序输出这三个字符。

Input

输入数据有多组,每组占一行,有三个字符组成,之间无空格。

Output

对于每组输入数据,输出一行,字符中间用一个空格分开。

Sample Input

qwe

asd

zxc

Sample Output

e q w

a d s

c x z

/*
    num:2000
    多组数据用gets结束是用NULL,不是EOF 
*/

/*
	num:2000
	多组数据用gets结束是用NULL,不是EOF 
*/

#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;

int main() {
	char a[3] = {};
	//string s;
	while(gets(a)!= NULL) {


		//gets(a);
		//a = s;
		sort(a,a+3);
		for(int i = 0; i < 3; i++) {
			if(i != 2)
				cout<<a[i]<<" ";
			else
				cout<<a[i]<<endl;
		}

	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/qing_feng__/article/details/86710570