杭电oj 2026

Problem Description

输入一个英文句子,将每个单词的第一个字母改成大写字母。

Input

输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。

Output

请输出按照要求改写后的英文句子。

Sample Input

 

i like acm i want to get an accepted

Sample Output

 

I Like Acm I Want To Get An Accepted

#include <cstdio>
#include <cstring>
char ss[105];

int main() {
	while(gets(ss)!=NULL) { //或者while(gets(ss))
		int len = strlen(ss);
		printf("%c",ss[0]-32);
		for (int i = 1; i < len; i++){
			if(ss[i] == ' ')
			{
				ss[i+1] = ss[i+1]-32;
			}
			printf("%c",ss[i]);
		}

		printf("\n");

		}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/qing_feng__/article/details/86747039