最简单的整数划分问题 HDU 1028

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24456    Accepted Submission(s): 16986


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
 
  
4 10 20
 

Sample Output
 
  
5 42 627
 

Author
Ignatius.L

f[n][m]表示把整数n分为最大不超过整数为m的个数。显然f[n][1]=1,当n<m时,f[n][m]=f[n][n]

f[1][m]=1,当n=m时,f[n][m]=f[n][m-1]+1

当n>m时,可以按最大数是否为m分类,如果最大是m,有f[n-m][m],如果最大不是m,f[n][m-1].

不需要递归,直接二重循环遍历就行

#include<iostream> 
#define maxn 121
using namespace std;
int dp[maxn][maxn];
int main()
{
	int i,j,n;
		for(int i=1;i<=121;i++)
		dp[1][i]=dp[i][1]=1;
		for(int i=2;i<121;i++)
		{
			for(int j=2;j<=121;j++)
			{
				if(i<j)
				{
					dp[i][j]=dp[i][i];
				}
				else if(i==j)
				{
					dp[i][j]=dp[i][j-1] + 1;
				}
				else
				{
					dp[i][j] = dp[i-j][j] + dp[i][j-1];
				} 
				
			}
		}
		while(cin>>n)
		{
			cout<<dp[n][n]<<endl;
		}
		
	
}



猜你喜欢

转载自blog.csdn.net/wwxy1995/article/details/80283456