Alice's Print Service(upper_bound)

Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.

Input

The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 10 5 ). The second line contains 2n integers s 1, p 1 , s 2, p 2 , ..., s n, p n (0=s 1 < s 2 < ... < s n ≤ 10 9 , 10 9 ≥ p 1 ≥ p 2 ≥ ... ≥ p n ≥ 0).. The price when printing no less than s i but less than s i+1 pages is p i cents per page (for i=1..n-1). The price when printing no less than s n pages is p n cents per page. The third line containing m integers q 1 .. q m (0 ≤ q i ≤ 10 9 ) are the queries.

Output

For each query q i, you should output the minimum amount of money (in cents) to pay if you want to print q i pages, one output in one line.

Sample Input

1
2 3
0 20 100 10
0 99 100

Sample Output

0
1000
1000

 和之前做过的买柠檬水差不多

#include <iostream>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <vector>
#define rush() int T;cin>>T;while(T--)
#define go(a) while(cin>>a)
#define ms(a,b) memset(a,b,sizeof a)
#define E 1e-8
using namespace std;
typedef long long ll;
const int idata=1e6+5;

int n,m,t,_;
int i,j,k;
ll cnt,num,ans;
ll minn,maxx;
//vector<int>v;
ll s[idata],p[idata];
ll f[idata];

int main()
{
    /*cin.tie(0);
    iostream::sync_with_stdio(false);*/
    rush()
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++){
            scanf("%lld%lld",s+i,p+i);
            f[i]=s[i]*p[i];
        }
        for(i=n;i>=1;i--){
            f[i-1]=min(f[i],f[i-1]);
        }
        f[n+1]=s[n+1]=INT_MAX;
        while(m--){
            cin>>t;
            int pos=upper_bound(s+1,s+1+n,t)-s;
            pos--;
            minn=min(t*p[pos],f[pos+1]);
            if(pos==n) minn=t*p[pos];
            printf("%lld\n",minn);
        }
        //system("pause");
    }
    return 0;
}
原创文章 410 获赞 16 访问量 3万+

猜你喜欢

转载自blog.csdn.net/C_Dreamy/article/details/105927758