BGP Lab ipv6

实验拓扑:


配置R1:
ipv6 unicast-routing

interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0/0
 ipv6 address 2001:1:1:1::1/64
!
interface Serial1/0
 ipv6 address 2001:A:A:A::1/64
!
interface Serial1/1
 ipv6 address 2001:B:B:B::1/64

router bgp 1
 no synchronization
 bgp router-id 1.1.1.1
 neighbor 2001:A:A:A::2 remote-as 2
 neighbor 2001:B:B:B::3 remote-as 3
 no auto-summary
 !
 address-family ipv6
 neighbor 2001:A:A:A::2 activate
 neighbor 2001:B:B:B::3 activate
 network 2001:1:1:1::/64
 exit-address-family

配置R2:
ipv6 unicast-routing

interface Loopback0
 ip address 2.2.2.2 255.255.255.0

interface Ethernet0/0
 ipv6 address 2001:2:2:2::2/64

interface Serial1/0
 ipv6 address 2001:A:A:A::2/64

router bgp 2
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 neighbor 2001:A:A:A::1 remote-as 1
 
 address-family ipv4
 neighbor 2001:A:A:A::1 activate
 no auto-summary
 no synchronization
 exit-address-family
 
 address-family ipv6
 neighbor 2001:A:A:A::1 activate
 network 2001:2:2:2::/64
 exit-address-family

配置R3:
ipv6 unicast-routing

interface Loopback0
 ip address 3.3.3.3 255.255.255.0

interface Ethernet0/0
 ipv6 address 2001:3:3:1::3/64
 ipv6 address 2001:3:3:2::3/64
 ipv6 address 2001:3:3:3::3/64
 ipv6 address 2001:3:3:4::3/64
 ipv6 address 2001:3:3:5::3/64
 ipv6 address 2001:3:3:6::3/64
 no keepalive

interface Serial1/0
 ipv6 address 2001:B:B:B::3/64

router bgp 3
 no synchronization
 bgp router-id 3.3.3.3
 neighbor 2001:B:B:B::1 remote-as 1
 no auto-summary
 
 address-family ipv6
 neighbor 2001:B:B:B::1 activate
 network 2001:3:3::/48
 exit-address-family

ipv6 route 2001:3:3::/48 Null0  要发布2001:3:3::/48 ,2001:3:3::/48必须先存在路由表中,才可以发布

验证IPv6 BGP4+
可以使用显示IPv6 BGP表的show bgp ipv6命令显示信息\ipv6 BGP邻居和统计信息,这个命令相当于IPV4中的show ip bgp 命令.

r2#show bgp ipv6 unicast ?
  X:X:X:X::X/<0-128>  IPv6 prefix <network>/<length>
  community           Display routes matching the communities
  community-list      Display routes matching the community-list
  dampening           Display detailed information about dampening
  extcommunity-list   Display routes matching the extcommunity-list
  filter-list         Display routes conforming to the filter-list
  inconsistent-as     Display only routes with inconsistent origin ASs
  labels              Display BGP labels for prefixes
  neighbors           Detailed information on TCP and BGP neighbor connections
  paths               Path information
  peer-group          Display information on peer-groups
  prefix-list         Display routes matching the prefix-list
  quote-regexp        Display routes matching the AS path "regular expression"
  regexp              Display routes matching the AS path regular expression
  replication         Display replication status of update-group(s)
  rib-failure         Display bgp routes that failed to install in the routing
                      table (RIB)
  route-map           Display routes matching the route-map
  summary             Summary of BGP neighbor status
  update-group        Display information on update-groups
  |                   Output modifiers
  <cr>
 

r2#show bgp ipv6 unicast 
BGP table version is 4, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2001:1:1:1::/64  2001:A:A:A::1            0             0 1 i
*> 2001:2:2:2::/64  ::                       0         32768 i
*> 2001:3:3::/48    2001:A:A:A::1                          0 1 3 i

r2#show bgp ipv6 unicast neighbors 
BGP neighbor is 2001:A:A:A::1,  remote AS 1, external link
  BGP version 4, remote router ID 1.1.1.1
  BGP state = Established, up for 00:27:17
  Last read 00:00:17, last write 00:00:17, hold time is 180, keepalive interval is 60 seconds

r2#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   2001:1:1:1::/64 [20/0]
     via FE80::CE00:3FF:FE68:0, Serial1/0
C   2001:2:2:2::/64 [0/0]
     via ::, Ethernet0/0
L   2001:2:2:2::2/128 [0/0]
     via ::, Ethernet0/0
B   2001:3:3::/48 [20/0]
     via FE80::CE00:3FF:FE68:0, Serial1/0
C   2001:A:A:A::/64 [0/0]
     via ::, Serial1/0
L   2001:A:A:A::2/128 [0/0]
     via ::, Serial1/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0
r2#

发布了309 篇原创文章 · 获赞 2 · 访问量 7355

猜你喜欢

转载自blog.csdn.net/qq_43207781/article/details/105691457