Printer Queue(链式队列实现)

The only printer in the computer science students’ union is experiencing an extremely heavy workload. Sometimes there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.

Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority,
and 1 being the lowest), and the printer operates as follows.
The first job J in queue is taken from the queue.
If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that’s life.

Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.
Input
One line with a positive integer: the number of test cases (at most 100). Then for each test case:
One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.

Output
For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.
Sample Input
3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1
Sample Output
1
2
5

#include <iostream>

using std::cout;
using std::endl;
using std::cin;

struct node
{
    int num;
    struct node* next;
    int flag;
};
typedef struct node nod;
typedef struct node* nodep;
class queue
{
    nodep head,rear;
    int maxSize,counter;
public:
    queue(int m);
    ~queue();
    void insert(int x,int n);
    void insert(int x,int n,int flag);
    int delete_();
    int getsize(){return maxSize;}
    int getCounter(){return counter;}
    int isMax();
    int peek();
};
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        int m,n;
        cin >> m >> n;
        //cout << m << endl << n <<endl;
        queue fu(m);
        for(int  i = 0;i < m;i++)
        {
            int x;
            cin >> x;
            fu.insert(x,n);
        }
        //cout << fu.isMax() << endl;
        while(fu.getCounter())
        {
            if(fu.isMax())
            {
                if(fu.peek())
                {
                    fu.delete_();
                    break;
                }
                else
                    fu.delete_();
            }
            else
            {
                int flag = fu.peek();
                fu.insert(fu.delete_(),1,flag);
            }

        }
        cout << fu.getsize() - fu.getCounter() << endl;
    }
    return 0;
}
int queue::isMax()
{
    nodep p = head->next;
    while(p->next)
        p = p->next;
    int max = p->num;
    p = head->next;
    for(int i = 0;i < counter - 1;i++)
    {
        if((p->num) > max)
            return 0;
        else
            p = p->next;
    }
    return 1;
}
int queue::delete_()
{
    counter--;
    nodep p0 = head,p = head;
    while(p->next)
    {
        p0 = p;
        p = p->next;
    }
    int temp = p->num;
    delete p;
    p0->next = NULL;
    return temp;
}
void queue::insert(int x,int n)
{
    counter++;
    nodep newNode = new nod;
    newNode->num = x;
    newNode->next = head->next;
    if(n == counter - 1)
        newNode->flag = 1;
    else newNode->flag = 0;
    head->next = newNode;
}
void queue::insert(int x,int n,int flag)
{
    counter++;
    nodep newNode = new nod;
    newNode->num = x;
    newNode->next = head->next;
    if(flag)
        newNode->flag = 1;
    else newNode->flag = 0;
    head->next = newNode;
}
queue::queue(int m)
{
    head = new nod;
    head->next = NULL;
    maxSize = m;
    counter = 0;
}
queue::~queue()
{
    nodep p0 = head,p = head->next;
    while(p)
    {
        delete p0;
        p0 = p;
        p = p->next;
    }
    delete p0;
}
int queue::peek()
{
    nodep p = head;
    while(p->next)
        p = p->next;
    return p->flag;
}
发布了39 篇原创文章 · 获赞 4 · 访问量 5756

猜你喜欢

转载自blog.csdn.net/weixin_45725137/article/details/105213323