Ants——(弹性碰撞问题)

题目

An army of ants walk on a horizontal pole of length l cm, each with a constant speed of 1 cm/s. When a walking ant reaches an end of the pole, it immediatelly falls off it. When two ants meet they turn back and start walking in opposite directions. We know the original positions of ants on the pole, unfortunately, we do not know the directions in which the ants are walking. Your task is to compute the earliest and the latest possible times needed for all ants to fall off the pole.

Input

The first line of input contains one integer giving the number of cases that follow. The data for each case start with two integer numbers: the length of the pole (in cm) and n, the number of ants residing on the pole. These two numbers are followed by n integers giving the position of each ant on the pole as the distance measured from the left end of the pole, in no particular order. All input integers are not bigger than 1000000 and they are separated by whitespace.

Output

For each case of input, output two numbers separated by a single space. The first number is the earliest possible time when all ants fall off the pole (if the directions of their walks are chosen appropriately) and the second number is the latest possible such time.

Sample Input

2
10 3
2 6 7
214 7
11 12 7 13 176 23 191

Sample Output

4 8
38 207

概括大意

有n只蚂蚁在木棍上爬行,每只蚂蚁的速度都是每秒1单位长度,现在给你所有蚂蚁初始的位置(蚂蚁运动方向未定),蚂蚁相遇会掉头反向运动,让你求出所有蚂蚁都·掉下木棍的最短时间和最长时间。

思路

首先碰撞的话,每只蚂蚁都会有两种选择,暴力复杂度为指数级,果断舍弃。

这道题就是碰撞后转向很让人不知所措,但我们可以很明显的发现,每只蚂蚁碰撞后,速度不变!

所以我们可以将它们看作碰撞后交叉行走,这样就摆脱了转向的问题。

思路明白了,代码很好写,将每个蚂蚁直接走向两端点的时间求出,这两个时间中只能取一个作为这个蚂蚁的时间,最终取最后一个掉下去的蚂蚁的时间即可。最短时间的话每只蚂蚁都最小,最大则反之。

代码

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=1000000+5;
int L,n,a[maxn];
int main(){
//	freopen("1.in","r",stdin);
	int t;
	scanf("%d",&t);
	while(t--){
		memset(a,0,sizeof(a));
		scanf("%d%d",&L,&n);
		for(int i=1;i<=n;++i){
			scanf("%d",&a[i]);
		}
		int Min=0,Max=0;
		for(int i=1;i<=n;++i){
			Min=max(Min,min(a[i],L-a[i]));
			Max=max(Max,max(a[i],L-a[i]));
		}
		printf("%d %d\n",Min,Max);
	}
	return 0;
} 

猜你喜欢

转载自www.cnblogs.com/Lour688/p/12702832.html