1061 Dating (20分)【字符串处理】

1061 Dating (20分)

Sherlock Holmes received a note with some strange strings: Let's date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 -- since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.

Input Specification:

Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.

Output Specification:

For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week -- that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.

Sample Input:

3485djDkxh4hhGE 
2984akDfkkkkggEdsb 
s&hgsfdk 
d&Hyscvnm

Sample Output:

THU 14:04

 题目大意:

给出4个字符串,其中前两个字符串包含两个信息:DAY和HH,后两个包含一个信息:MM

下面给出这个信息的识别信息和转换关系:
DAY:前两个字符串的第一对相同位置的A~G的大写字母。大写字母是从A开始的第几个,就是星期几。

HH:寻找信息DAY后的第一对相同位置的0~9或A~N的字符。0~9对应0~9,A~N对应10~23。

MM:后两个字符串的第一个相同位置的A~Z或a~z的英文字母。该字符所在的位置即MM。

#include<iostream>
#include<string>
using namespace std;

string week[7] = { "MON","TUE","WED","THU","FRI","SAT","SUN" };

int main()
{
	string str1, str2, str3, str4;
	cin >> str1 >> str2 >> str3 >> str4;
	int len1 = str1.length();
	int len2 = str2.length();
	int len3 = str3.length();
	int len4 = str4.length();
	int i;
	for (i = 0; i < len1&&i < len2; i++)
	{
		if (str1[i] == str2[i] && str1[i] >= 'A'&&str1[i] <= 'G')
		{
			cout << week[str1[i] - 'A']<<" ";
			break;
		}
	}
	for (i++; i < len1&&i < len2; i++)
	{
		if (str1[i] == str2[i])
		{
			if (str1[i] >= '0'&&str1[i] <= '9')
			{
				printf("%02d:", str1[i] - '0');
				break;
			}
			else if (str1[i] >= 'A'&&str1[i] <= 'N')
			{
				printf("%02d:", str1[i] - 'A' + 10);
				break;
			}
		}
	}
	for (i = 0; i < len3&&i < len4; i++)
	{
		if (str3[i] == str4[i]&&((str3[i]>='A'&&str3[i]<='Z')||(str3[i]>='a'&&str3[i]<='z')))
		{
			printf("%02d\n", i);
			break;
		}
	}
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104635734