Dead Fraction(poj1930)

Mike is frantically scrambling to finish his thesis at the last minute. He needs to assemble all his research notes into vaguely coherent form in the next 3 days. Unfortunately, he notices that he had been extremely sloppy in his calculations. Whenever he needed to perform arithmetic, he just plugged it into a calculator and scribbled down as much of the answer as he felt was relevant. Whenever a repeating fraction was displayed, Mike simply reccorded the first few digits followed by "...". For instance, instead of "1/3" he might have written down "0.3333...". Unfortunately, his results require exact fractions! He doesn't have time to redo every calculation, so he needs you to write a program (and FAST!) to automatically deduce the original fractions. 
To make this tenable, he assumes that the original fraction is always the simplest one that produces the given sequence of digits; by simplest, he means the the one with smallest denominator. Also, he assumes that he did not neglect to write down important digits; no digit from the repeating portion of the decimal expansion was left unrecorded (even if this repeating portion was all zeroes).
Input
There are several test cases. For each test case there is one line of input of the form "0.dddd..." where dddd is a string of 1 to 9 digits, not all zero. A line containing 0 follows the last case.
Output
For each case, output the original fraction.
Sample Input
0.2...
0.20...
0.474612399...
0
Sample Output
2/9
1/5
1186531/2500000
Hint

Note that an exact decimal fraction has two repeating expansions (e.g. 1/5 = 0.2000... = 0.19999...).

通过枚举循坏节,找出最小的分母,首先还是得学会小数如何转化为分数。

传送门

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

typedef long long LL;

char str[20];

LL gcd(LL minn,LL maxn)
{
    return minn==0?maxn:gcd(maxn%minn,minn);
}

int main()
{
    while(~scanf("%s",str)){
        if(strcmp(str,"0")==0){
            break;
        }else{
            int len=strlen(str),point;
            for(int i=2;i<len;i++){
                if(str[i]=='.'){
                    point=i;
                    break;
                }
            }
            LL ans_num=0x3f3f3f3f,ans_cnt;
            for(int i=2;i<point;i++){
                int j=i-2;
                LL cnt=0,num=0;
                for(int k=i;k<point;k++){
                    cnt=cnt*10+(str[k]-'0');
                    num=num*10+9;
                }
                int inter=0;
                for(int k=2;k<i;k++){
                    inter=inter*10+(str[k]-'0');
                }
                cnt+=inter*num;
                for(int k=0;k<j;k++){
                    num*=10;
                }
                LL res=gcd(num,cnt);
                cnt/=res;
                num/=res;
                if(num<ans_num){
                    ans_num=num;
                    ans_cnt=cnt;
                }
            }
            printf("%lld/%lld\n",ans_cnt,ans_num);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zhouzi2018/article/details/80318692