《算法笔记》6.2小节——C++标准模板库(STL)介绍->set的常见用法详解

目录

问题 A: Set Similarity (25)


问题 A: Set Similarity (25)

题目描述

Given two sets of integers, the similarity of the sets is defined to be Nc/Nt*100%, where Nc is the number of distinct common numbers shared by the two sets, and Nt is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

输入

Each input file contains one test case. Each case first gives a positive integer N (<=50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (<=104) and followed by M integers in the range [0, 109]. After the input of sets, a positive integer K (<=2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

输出

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

样例输入

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

样例输出

50.0%
33.3%

题解

#include <cstdio>
#include <cstring>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
const int maxn = 60;
set<int> Array[maxn];
int main(){
	int N, M, K;
	int Nc, Nt;
	scanf("%d", &N);
	int i, j;
	for(i = 1; i <= N; i++){
		scanf("%d", &M);
		for(j = 0; j < M; j++){
			int temp;
			scanf("%d", &temp);
			Array[i].insert(temp);
		}
	}
	scanf("%d", &K);
	while(K--){
		int a, b;
		scanf("%d%d", &a, &b);
		Nc = 0;
		for(set<int>::iterator it = Array[a].begin(); it != Array[a].end(); it++){
			if(Array[b].find(*it) != Array[b].end()){//在b中找a的各个元素是否存在
				Nc++;
			}
		}
		Nt = Array[a].size() + Array[b].size() - Nc;
		printf("%.1f%%\n", (double)Nc / Nt * 100);
	}
	return 0;
}
发布了160 篇原创文章 · 获赞 175 · 访问量 4万+

猜你喜欢

转载自blog.csdn.net/wyatt007/article/details/105009570
今日推荐