1136 A Delayed Palindrome (20 分) 【大数加法】

Consider a positive integer N written in standard notation with k+1 digits ai as ak…a1a0 with 0 <= ai < 10 for all i and ak > 0. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 and is also palindromic by definition.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. Such number is called a delayed palindrome. (Quoted from https://en.wikipedia.org/wiki/Palindromic_number)

Given any positive integer, you are supposed to find its paired palindromic number.

Input Specification:

Each input file contains one test case which gives a positive integer no more than 1000 digits.

Output Specification:

For each test case, print line by line the process of finding the palindromic number. The format of each line is the following:

A + B = C
where A is the original number, B is the reversed A, and C is their sum. A starts being the input number, and this process ends until C becomes a palindromic number — in this case we print in the last line “C is a palindromic number.”; or if a palindromic number cannot be found in 10 iterations, print “Not found in 10 iterations.” instead.

Sample Input 1:
97152
Sample Output 1:
97152 + 25179 = 122331
122331 + 133221 = 255552
255552 is a palindromic number.
Sample Input 2:
196
Sample Output 2:
196 + 691 = 887
887 + 788 = 1675
1675 + 5761 = 7436
7436 + 6347 = 13783
13783 + 38731 = 52514
52514 + 41525 = 94039
94039 + 93049 = 187088
187088 + 880781 = 1067869
1067869 + 9687601 = 10755470
10755470 + 07455701 = 18211171
Not found in 10 iterations.


题目大意:
一个数加它的翻转能否在10次内得到一个回文数

分析:
模拟大数加法

错误记录
没有考虑一开始就是回文的情况

#include <bits/stdc++.h>
using namespace std;
string rev(string str)
{
    reverse(str.begin(), str.end());
    return str;
}

bool isPali(string str)
{
    if (str == rev(str))
    {
        cout << str << " is a palindromic number." << endl;
        return true;
    }
    return false;
}

string add(string a, string b) {
    string c = a;
    int carry = 0;
    for (int i = a.size() - 1; i >= 0; i--) {
        c[i] = (a[i] - '0' + b[i] - '0' + carry) % 10 + '0';
        carry = (a[i] - '0' + b[i] - '0' + carry) / 10;
    }
    if (carry > 0) c = "1" + c;
    return c;
}

string calc(string num)
{
    string revnum = rev(num);
    string ans = add(num, revnum);
    cout << num << " + " << revnum << " = " << ans << endl;
    return ans;
}

int main()
{
    string num;
    cin >> num;
    
    int k = 10;
    while (k--)
    {
        if (isPali(num)) break;
        num = calc(num);
    }
    
    if (k == -1) cout << "Not found in 10 iterations." << endl;
    return 0;

}
发布了673 篇原创文章 · 获赞 644 · 访问量 38万+

猜你喜欢

转载自blog.csdn.net/zhaohaibo_/article/details/90345533