PTA 04-树5 Root of AVL Tree (25分)

                                            04-树5 Root of AVL Tree (25分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88
#include<stdio.h>
#include<stdlib.h>
typedef struct AVLNode *Position;
typedef Position AVLTree;
struct AVLNode{
	int Data;
	AVLTree Left;
	AVLTree Right;
	int Height;
};

int Max ( int a, int b ){
	return a>b?a:b;
}
int GetHeight( AVLTree A ){
	int height;
	if(!A){
		height = 0;
	}else{
		height = A->Height;
	}

	return height;
}
AVLTree SingleLeftRotation ( AVLTree A ){
	AVLTree B = A->Left;
	A->Left = B->Right;
	B->Right = A;
	A->Height = Max( GetHeight(A->Left), GetHeight(A->Right) ) + 1;
    B->Height = Max( GetHeight(B->Left), A->Height ) + 1;
	return B;
}
AVLTree SingleRightRotation ( AVLTree A ){
	AVLTree B = A->Right;
	A->Right = B->Left;
	B->Left = A;
	A->Height = Max( GetHeight(A->Left), GetHeight(A->Right) ) + 1;
    B->Height = Max( GetHeight(B->Left), A->Height ) + 1;
	return B;
}
AVLTree DoubleLeftRightRotation ( AVLTree A ){
	A->Left = SingleRightRotation(A->Left);
	return SingleLeftRotation(A);
}
AVLTree DoubleRightLeftRotation ( AVLTree A ){
	A->Right = SingleLeftRotation(A->Right);
	return SingleRightRotation(A);
}
AVLTree Insert( AVLTree T, int X ){
	if(!T){
		T = (AVLTree)malloc(sizeof(struct AVLNode));
		T->Data = X;
		T->Left = T->Right = NULL;
		T->Height = 0;
	}else if(X > T->Data){
		T->Right = Insert(T->Right,X);
		if(GetHeight(T->Right) - GetHeight(T->Left) == 2){
			if(X > T->Right->Data){
				T = SingleRightRotation(T);
			}else{
				T = DoubleRightLeftRotation(T);
			}
		}
	}else if(X < T->Data){
		T->Left = Insert(T->Left,X);
		if(GetHeight(T->Right) - GetHeight(T->Left) == -2){
			if(X < T->Left->Data){
				T = SingleLeftRotation(T);
			}else{
				T = DoubleLeftRightRotation(T);
			}
		}
	}else{
		return NULL;//重复为有误 
	}
	T->Height = Max(GetHeight(T->Left),GetHeight(T->Right)) + 1;
	return T;
}

int main(){
	int i,N,X;
	AVLTree T = NULL;
	scanf("%d",&N);
	if(N<=20){
		while(N--){
			scanf("%d",&X);
			T = Insert(T,X);
		}
		printf("%d",T->Data);
	}
	return 0;

}
发布了9 篇原创文章 · 获赞 10 · 访问量 1205

猜你喜欢

转载自blog.csdn.net/Young_IT/article/details/105020219