POJ - 2559——Largest Rectangle in a Histogram (单调队列之火车厢)

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000
Hint

Huge input, scanf is recommended.


题意: N辆小车并排在一起,每辆小车的宽度都是1,N辆小车走过的路径组成N个并排的矩形,给出每辆小车i前进的距离ai,他要在他的小车走过的地方画出一个尽可能大的矩形。但是,宗学长要去修他的小车,于是他把这个问题抛给了你,机智的你能帮学长求出这个最大矩形的面积吗?
思路:单调栈水题。
#include<algorithm>
#include<string.h>
#include<stdio.h>
#define M 100010
using namespace std;
struct node
{
    long long x,i;
};
node q[M];
int main()
{
    int n;
    node p;
    long long ans;
    while(~scanf("%d",&n),n)
    {
        int tail=0;
        ans=0;
        for(int i=0; i<n; i++)
        {
            scanf("%lld",&p.x);
            int l=0;
            while(tail>0&&q[tail-1].x>=p.x)
            {
                q[tail-1].i+=l;
                l=q[tail-1].i;
                if(ans<q[tail-1].x*q[tail-1].i)
                    ans=q[tail-1].x*q[tail-1].i;
                tail--;
            }
            q[tail].x=p.x;
            q[tail++].i=l+1;
        }
        int l=0;
        while(tail>0)
        {
            q[tail-1].i+=l;
            l=q[tail-1].i;
            if(ans<q[tail-1].x*q[tail-1].i)
                ans=q[tail-1].x*q[tail-1].i;
            tail--;
        }
        printf("%lld\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/80400839