Ace of Aces

There is a mysterious organization called Time-Space Administrative Bureau (TSAB) in the deep universe that we humans have not discovered yet. This year, the TSAB decided to elect an outstanding member from its elite troops. The elected guy will be honored with the title of "Ace of Aces".

After voting, the TSAB received N valid tickets. On each ticket, there is a number Ai denoting the ID of a candidate. The candidate with the most tickets nominated will be elected as the "Ace of Aces". If there are two or more candidates have the same number of nominations, no one will win.

Please write program to help TSAB determine who will be the "Ace of Aces".

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 1000). The next line contains N integers Ai (1 <= Ai <= 1000).

<h4< dd="">Output

For each test case, output the ID of the candidate who will be honored with "Ace of Aces". If no one win the election, output "Nobody" (without quotes) instead.

<h4< dd="">Sample Input
3
5
2 2 2 1 1
5
1 1 2 2 3
1
998
<h4< dd="">Sample Output
2
Nobody
998

#include <iostream>
#include <string.h>
using namespace std;
#include <stdio.h>
int main()
{
    int t,n,a[10000],i,flag[3333]={0};
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        memset(a,0,sizeof(a));
        memset(flag,0,sizeof(flag));
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            flag[a[i]]++;
        }
        int maxx=0,maxx2=0,c=0,d=0;
        for(i=0;i<3333;i++)
        {
            if(flag[i]>maxx)
            {
                maxx=flag[i];
                c=i;
            }
        }
        for(i=0;i<3333;i++)
        {
            if(flag[i]>maxx2&&i!=c)
            {
                maxx2=flag[i];
                d=i;
            }
        }
        if(maxx==maxx2)
            printf("Nobody\n");
        else
            printf("%d\n",c);
    }
    return 0;
}

下面是map做法

#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <map>
using namespace std;
map<int,int> mp;
int main()
{
    int t,n,i,a;
    map<int,int>::iterator it;
    scanf("%d",&t);
    while(t--)
    {
        int k=0,ans=0,m=0;
        scanf("%d",&n);
        mp.clear();
        for(i=0;i<n;i++)
        {
            scanf("%d",&a);
            mp[a]++;
            k=max(mp[a],k);
        }
        for(it=mp.begin();it!=mp.end();it++)
        {
            if(it->second==k)
            {
                ans=it->first;
                m++;
            }
        }
        if(m==1)
            printf("%d\n",ans);
        else
            printf("Nobody\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zcy19990813/article/details/80112600
ACE