算法——Quick Sort

题目描述

Quicksort is a well-known sorting algorithm developed by C. A. R.

Hoare that, on average, makes Θ(n log n) comparisons to sort n items. However, in the worst case, it makes Θ(n2) comparisons. Typically, quicksort is significantly faster in practice than other Θ(n log n) algorithms, because its inner loop can be efficiently implemented on most architectures, and in most real-world data it is possible to make design choices which minimize the possibility of requiring quadratic time.

Quicksort sorts by employing a divide and conquer strategy to divide a list into two sub-lists.

The steps are:

  1. Pick an element, called a pivot, from the list.

  2. Reorder the list so that all elements which are less than the pivot come before the pivot and so that all elements greater than the pivot come after it (equal values can go either way). After this partitioning, the pivot is in its final position. This is called the partition operation.

  3. Recursively sort the sub-list of lesser elements and the sub-list of greater elements. The base case of the recursion are lists of size zero or one, which are always sorted. The algorithm always terminates because it puts at least one element in its final place on each iteration (the loop invariant).

Quicksort in action on a list of random numbers. The horizontal lines are pivot values. Write a program to sort ascending int number by QuickSort ,n less than 50000.

输入

two lows, the first low is numbers , less and equal than 50000. the second low is a set integer numbers

输出

a set integer numbers of sort ascending

样例输入

10
4 2 1 5 7 6 9 8 0 3

样例输出

0 1 2 3 4 5 6 7 8 9

代码

#include<iostream>
using namespace std;
void quick_sort(int *arr, int left , int right){
	int i = left, j = right;
	int X = arr[i] ;
	while(i < j){
		while(arr[j] > X && i < j) 
		{
			j--;
		}
		if(i < j)
			arr[i++] = arr[j];
		while(arr[i] <= X && i < j){
			i++;
		}
		if(i < j)
			arr[j--] = arr[i];
	}
	arr[i] = X;
	if( i > left) quick_sort(arr, left,i - 1);
	if( j < right ) quick_sort(arr , j + 1, right);
	return ;
}
int main(){
	int n;
	cin>>n;
	int arr[50000];
	for(int i = 0; i < n ; i++){
		cin>>arr[i];
	}
	int left = 0, right = n - 1;
	quick_sort(arr, left , right);
	for(int i = 0; i < n ; i++){
		cout<<arr[i]<<' ';
	}
	cout<<endl;
	return 0;
} 

思路

1.很好的体现了分治思想;
2.选择一个中间值,一般是第一个位置的数值,从左至右、从右至左,比较中间值和数组元素,小或等于放左,大放右。这样是一次排序;
3.上面显示的是递归的方法,不断重复 2 ,排序成功退出;
4.arr[i++] = arr[j];或者arr[j–] = arr[i];要用 if 语句判断,否则可能会 Time Limit Exceeded。

发布了9 篇原创文章 · 获赞 72 · 访问量 3877

猜你喜欢

转载自blog.csdn.net/qq_45703420/article/details/105173086