和風いろはちゃんイージー / Iroha and Haiku (ABC Edition) AtCoder - 1977 这也太水题了

和風いろはちゃんイージー / Iroha and Haiku (ABC Edition)

  AtCoder - 1977 

 Problem Statement

 

Iroha loves Haiku. Haiku is a short form of Japanese poetry. A Haiku consists of three phrases with 57 and 5 syllables, in this order.

To create a Haiku, Iroha has come up with three different phrases. These phrases have AB and C syllables, respectively. Determine whether she can construct a Haiku by using each of the phrases once, in some order.

Constraints

 

  • 1≦A,B,C≦10

Input

 

The input is given from Standard Input in the following format:

A B C

Output

 

If it is possible to construct a Haiku by using each of the phrases once, print YES(case-sensitive). Otherwise, print NO.

Sample Input 1

 

5 5 7

Sample Output 1

 

YES

Using three phrases of length 55 and 7, it is possible to construct a Haiku.

Sample Input 2

 

7 7 5

Sample Output 2

 

NO
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
#include<utility>
#include<set>
#include<vector>
#include<map>
#include<queue>
#include<stack>
#define maxn 1010
#define INF 0x3f3f3f3f
#define LL long long
#define ULL unsigned long long
#define E 1e-8
#define mod 1000000007
#define P pair<int,int>
using namespace std;
int main()
{
    int a[3];
    while(cin>>a[0]>>a[1]>>a[2])
        {
            int sum = 0,sum2 = 0;
        for(int i=0;i<3;i++){
            if(a[i] == 5)
            sum++;
        else
            if(a[i] == 7)
            sum2++;
        }
        if((sum == 2) && (sum2 == 1))
            cout << "YES" <<endl;
        else
            cout<<"NO"<<endl;
    }
}

猜你喜欢

转载自www.cnblogs.com/upstart/p/8982409.html
今日推荐