PAT 甲 1061 Dating

Sherlock Holmes received a note with some strange strings: Let’s date! 3485djDkxh4hhGE 2984akDfkkkkggEdsb s&hgsfdk d&Hyscvnm. It took him only a minute to figure out that those strange strings are actually referring to the coded time Thursday 14:04 – since the first common capital English letter (case sensitive) shared by the first two strings is the 4th capital letter D, representing the 4th day in a week; the second common character is the 5th capital letter E, representing the 14th hour (hence the hours from 0 to 23 in a day are represented by the numbers from 0 to 9 and the capital letters from A to N, respectively); and the English letter shared by the last two strings is s at the 4th position, representing the 4th minute. Now given two pairs of strings, you are supposed to help Sherlock decode the dating time.
Input Specification:
Each input file contains one test case. Each case gives 4 non-empty strings of no more than 60 characters without white space in 4 lines.
Output Specification:
For each test case, print the decoded time in one line, in the format DAY HH:MM, where DAY is a 3-character abbreviation for the days in a week – that is, MON for Monday, TUE for Tuesday, WED for Wednesday, THU for Thursday, FRI for Friday, SAT for Saturday, and SUN for Sunday. It is guaranteed that the result is unique for each case.
Sample Input:
3485djDkxh4hhGE
2984akDfkkkkggEdsb
s&hgsfdk
d&Hyscvnm
Sample Output:
THU 14:04
题意:
与乙级1014题相同
在这里插入图片描述
在这里插入图片描述
思路:
循环根据所给方法找符合要求的位置即可,注意字母与字母序号转换:s1[i]-‘A’,注意输出格式%02d
C++代码:

#include<cstdio>
#include<iostream>
#include<string>
using namespace std; 
int main(){
	string s1,s2,s3,s4;
	cin>>s1>>s2>>s3>>s4;
	int i=0,count1=0,count2=0,count3=0;
	for(i=0;i<s1.length()&&i<s2.length();i++){
		if(s1[i]==s2[i]&&s1[i]>='A'&&s2[i]<='G'){
			count1=s1[i]-'A';
			break;		
		} 
	}
	for(i=i+1;i<s1.length()&&i<s2.length();i++){
		if(s1[i]==s2[i]&&(s1[i]>='A'&&s2[i]<='N')){
			count2=s1[i]-'A'+10;
			break;		
		} 
		else if(s1[i]==s2[i]&&(s1[i]<='9'&&s1[i]>='0')){
			count2=s1[i]-'0';
			break;
		} 
	}
	for(int j=0;j<s3.length()&&j<s4.length();j++){
		if(s3[j]==s4[j]&&((s3[j]>='A'&&s3[j]<='z')||s3[j]>='A'&&s3[j]<='z')){
			count3=j;
			break;
		}
	}
	string week[7]={"MON", "TUE", "WED", "THU", "FRI", "SAT", "SUN"};
	cout<<week[count1]<<" ";
	printf("%02d:%02d\n",count2,count3);	
	return 0;	
}
发布了65 篇原创文章 · 获赞 5 · 访问量 4147

猜你喜欢

转载自blog.csdn.net/u014424618/article/details/105044199