HDU - 2222——Keywords Search(AC自动机模板题)

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
Input First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
Output Print how many keywords are contained in the description. Sample Input
1
5
she
he
say
shr
her
yasherhs
Sample Output
 
 

3


题意:给N个字符串,和一个主串,求N个字符串中一共有多少个在主串出现过。

思路:裸的AC自动机。AC自动机今天看了一个早上,外加半个下午,终于看懂了一点皮毛。
AC自动机博客:

                       https://blog.csdn.net/creatorx/article/details/71100840
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
char a[70],s[1000010];
struct node
{
    int v;
    node *next[26];
    node *fail;
};
node root;
node *que[1000010];
int cut;
void init(node *q)
{
    for(int i=0; i<26; i++)
    {
        q->next[i]=NULL;
    }
    q->v=0;
    q->fail=NULL;
}
void Trie_creat(char *str)
{
    node *p=&root,*q;
    while(*str)
    {
        int di=*str-'a';
        if(p->next[di]==NULL)
        {
            q=(node *)malloc(sizeof(node));
            init(q);
            p->next[di]=q;
        }
        p=p->next[di];
        str++;
    }
    p->v++;
}
void init_AC_automatiom()
{
    int head=0,tail=0;
    que[tail++]=&root;
    node *temp,*p;
    while(head<tail)
    {
        temp=que[head++];
        for(int i=0;i<26;i++)
        {
            if(temp->next[i])
            {
                if(temp==&root)
                {
                    temp->next[i]->fail=&root;
                }
                else
                {
                    p=temp->fail;
                    while(p)
                    {
                        if(p->next[i])
                        {
                            temp->next[i]->fail=p->next[i];
                            break;
                        }
                        p=p->fail;
                    }
                    if(p==NULL)temp->next[i]->fail=&root;
                }
                que[tail++]=temp->next[i];
            }
        }
    }
}
int AC_automation(char *str)
{
    node *p=&root,*temp;
    while(*str)
    {
        int di=*str-'a';
        while(p->next[di]==NULL&&p!=&root)p=p->fail;
        p=p->next[di];
        if(!p)p=&root;
        temp=p;
        while(temp!=&root)
        {
            if(temp->v>=0)
            {
                cut+=temp->v;
                temp->v=-1;
            }
            else break;
            temp=temp->fail;
        }
        str++;
    }
}
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        init(&root);
        cut=0;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            scanf("%s",a);
            Trie_creat(a);
        }
        init_AC_automatiom();
        scanf("%s",s);
        AC_automation(s);
        printf("%d\n",cut);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/80324619