hdu 2648

 

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2648

 

Shopping

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6022    Accepted Submission(s): 2109


 

Problem Description
Every girl likes shopping,so does dandelion.Now she finds the shop is increasing the price every day because the Spring Festival is coming .She is fond of a shop which is called "memory". Now she wants to know the rank of this shop's price after the change of everyday.
 
Input
One line contians a number n ( n<=10000),stands for the number of shops.
Then n lines ,each line contains a string (the length is short than 31 and only contains lowercase letters and capital letters.)stands for the name of the shop.
Then a line contians a number m (1<=m<=50),stands for the days .
Then m parts , every parts contians n lines , each line contians a number s and a string p ,stands for this day ,the shop p 's price has increased s.
 
Output
Contains m lines ,In the ith line print a number of the shop "memory" 's rank after the ith day. We define the rank as :If there are t shops' price is higher than the "memory" , than its rank is t+1.
 
Sample Input
 
3
memory
kfc
wind
2
49 memory
49 kfc
48 wind
80 kfc
85 wind
83 memory
Sample Output
 
1
 
2
 
#include<iostream>
#include<algorithm>
#include<map>
using namespace std;

int main()
{
	int n,m;
	
	while(cin>>n)
	{
		map<string,int> shop;
		
		int temp=n; 
			while(temp--)
		{
			string name;
			cin>>name;
			shop[name]=0;
		}
		cin>>m;
		while(m--)
		{
			int j=0;
			int rank=1;
			for(int i=0;i<n;i++)
			{
				int value;
				string name;
				cin>>value>>name;
				shop[name]+=value;
			}
			
			map<string,int>::iterator it;
			for(it=shop.begin();it!=shop.end();it++)
			if(it->second>shop["memory"])
			rank++;
			cout<<rank<<endl;
			
		}
		shop.clear(); 
	} 
	
	return 0;
} 
发布了44 篇原创文章 · 获赞 72 · 访问量 3万+

猜你喜欢

转载自blog.csdn.net/cj151525/article/details/103517772