Power Strings [section] KMP cycle

Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
. 3
Hint
This problem has Huge INPUT, INSTEAD Scanf use of CIN to Avoid Time limit Exceed.
Problem-solving ideas:
A typical cycle request section kmp subject. Analyzing n% (nf [n]) is equal to 0, if zero is not the string of a plurality of identical strings, n / (nf [n] ) is the desired answer.
Code

#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;
const int N = 1000005;
char s[N];
int f[N];
int len;
void getfail(){
    f[0]=0,f[1]=0;
    int j;
    for(int i=1;i<len;i++){
        j=f[i];
        while(j&&s[i]!=s[j]) j=f[j];
        f[i+1]= s[i]==s[j]?j+1:0;
    }
}
int main(){
    while(~scanf("%s",s),s[0]!='.'){
        len=strlen(s);
        getfail();
        if(len%(len-f[len])==0)
            printf("%d\n",len/(len-f[len]));
        else
            printf("1\n");

    }

    return 0;
}

Published 156 original articles · won praise 9 · views 6533

Guess you like

Origin blog.csdn.net/weixin_43438700/article/details/102818335
Recommended