[Kuangbin take you to fly] KMP & topic sixteen extended KMP & Manacher: G - Power Strings POJ - 2406 (kmp simple cycle section)

[Kuangbin take you to fly] KMP & topic sixteen extended KMP & Manacher

G - Power Strings

POJ - 2406

topic:

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
ABCD is 
AAAA 
ababab 
.
Sample Output
1
4
3
Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Meaning of the title: the number of cycles required string section
Thinking: If the character string to be noted that if not all of the circulating composition outputting -1 if the loop section is composed, then the n-nextt [n] is the loop section length, with this length is divided by the total length of the cycle Day length
 
// 
// Created by HJYL on 2019/8/15.
//
#include <iostream>
#include <vector>
#include <map>
#include <string>
#include <queue>
#include <stack>
#include <set>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
using namespace std;
const int maxn=1e7+10;
char str[maxn];
int nextt[maxn];
void getnextt()
{
    int i=0,j=-1;
    nextt[0]=-1;
    int n=strlen(str);
    while(i<n)
    {
        if(j==-1||str[i]==str[j])
        {
            i++,j++;
            if(str[i]!=str[j])
                nextt[i]=j;
            else
                nextt[i]=nextt[j];
        } else
            j=nextt[j];
    }
}
int main()
{
    //freopen("C:\\Users\\asus567767\\CLionProjects\\untitled\\text","r",stdin);
    while(~scanf("%s",str))
    {
        if(str[0]=='.')
            break;
        int len=strlen(str);
        getnextt();
        if(len%(len-nextt[len])==0)
         printf("%d\n",len/(len-nextt[len]));
        else
            printf("1\n");
    }
    return 0;
}

 

 

 
 

Guess you like

Origin www.cnblogs.com/Vampire6/p/11360900.html