HDU-4496-D-City (disjoint-set basis)

D-City

Problem Description

Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input

First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output

Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input

5 10 
0 1 
1 2 
1 3 
1 4 
0 2 
2 3 
0 4 
0 3 
3 4 
2 4
 

Sample Output

1 
1 
1 
2 
2 
2 
2 
3 
4 
5
Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. 
The first 3 lines of output are 1s  because  after  deleting  the  first  3  edges  of  the  graph,  all  vertexes  still  connected together. 
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. 
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N. 

Problem-solving ideas:

Title well appreciated to one of n nodes m FIG edges.
FIG whole blocks when the number of communication request to delete before i edges.
Communication request blocks may naturally occur disjoint-set, and then delete the case where the requirements of edges before i.
Consideration may be reversed, the number of communication block is added after considering i article, backwards and then output on the bin.

AC Code:

#include <bits/stdc++.h>
#include <utility>
#include <string>
#define int long long
using namespace std;
const int mod = 1e9+7;
const int N = 2e5+10;
int a[N];
int p[N];

struct node{
    int x,y;
}nodes[N];

int _find(int x)
{
    return p[x] == x ? x : p[x] =  _find(p[x]);
}

signed main()
{
    int n,m;
    while(~scanf("%lld%lld",&n,&m))
    {
        for(int i = 0 ; i < m ; i ++)
            scanf("%lld%lld",&nodes[i].x,&nodes[i].y);
        for(int i = 0 ; i < n ; i ++)
            p[i] = i;
        int ans = n;
        for(int i = m-1 ; i >= 0 ; i --)
        {
            int pa = _find(nodes[i].x);
            int pb = _find(nodes[i].y);
            if( pa != pb )
            {
                p[pa]  = pb;
                a[i] = ans--;
            }
            else
                a[i] = ans;
        }
        for(int i = 0 ; i < m ; i ++)
            printf("%lld\n",a[i]);
    }
    return 0;
}

Published 104 original articles · won praise 7 · views 4071

Guess you like

Origin blog.csdn.net/qq_43461168/article/details/104127418