+ Fast ride fast power board zhx's contest

As one of the most powerful brushes, zhx is required to give his juniors nn problems.
zhx thinks the ithith problem's difficulty is ii. He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai}{ai} beautiful if there is an ii that matches two rules below:
1: a1..aia1..ai are monotone decreasing or monotone increasing.
2: ai..anai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module pp.

InputMultiply test cases(less than 10001000). Seek EOFEOF as the end of the file.
For each case, there are two integers nn and pp separated by a space in a line. (1n,p10181≤n,p≤1018)
OutputFor each test case, output a single line indicating the answer.
Sample Input

2 233
3 5

Sample Output

2
1


        
 

Hint

The In The First Case, both Sequence {. 1, 2} and {2,. 1} are Legal. 
The In The SECOND Case, Sequence {. 1, 2,. 3}, {. 1,. 3, 2}, {2,. 1,. 3} , {2, 3, 1} , {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1 ideas: flag minimum and maximum values (think of the image) so for every sign that you need to choose some number on the left to the right will be able to become monotonous become monotonous and program number 1 so the answer is sigema (1-> n-1) C (i) (n-1) introduced through by Pascal's triangle term of equation 2 ^ n-2; board ( fast rapid power board by board and have the same purpose )
        








// 
#include<bits/stdc++.h> 
using namespace std; 
#define ll long long 
ll n,p; 
#define maxnn 100100 
ll ksc(ll a,ll b,ll c)
{
    a=a%c;
    ll ans=0;
    while(b)
    {
        if(b&1) ans=(ans+a)%c;
        b>>=1;
        a=(a+a)%c;
    }
    return ans;
}
ll ksm(ll a,ll b,ll c)
{
    a=a%c;
    ll ans=1;
    while(b)
    {
        if(b&1) ans=ksc(ans,a,c)%c;
        b>>=1;
        a=ksc(a,a,c)%c;
    }
    return ans;
}
int main()
{
    while(cin>>n)
    {
        cin>>p;
        printf("%lld\n",(ksm(2,n,p)-2+p)%p);
    }
}

 

Guess you like

Origin www.cnblogs.com/OIEREDSION/p/11291717.html