Huawei eNSP configures link aggregation (manual aggregation mode)

Link aggregation overview

Link aggregation treats multiple physical interfaces as one logical interface to increase bandwidth and provide line redundancy. The bandwidth of link aggregation is theoretically equivalent to the total bandwidth of the physical interfaces included, which is very suitable for enterprise core In the network, if a member interface or link participating in the bundling is damaged, it will not affect the normal operation of the aggregated link and provide redundancy. The link aggregation protocol supported by Huawei equipment is LACP (Link Aggregation Control Protocol). In Huawei equipment, multiple physical interfaces are bundled into a logical interface, which is called an Eth-Trunk interface. Standards related to link aggregation are defined by IEE 802.3ad.

link aggregation mode

The link aggregation modes supported by Huawei equipment include manual load balancing mode and static LACP mode.

Manual load sharing mode: Manual load sharing mode does not involve the participation of LACP protocol messages, and all configurations are completed manually, such as adding multiple member interfaces. In this mode, all interfaces are in the forwarding state to realize link load balancing. The load sharing methods it supports include destination MAC, source MAC, source MAC XOR destination MAC, source IP, destination IP, source IP XOR destination IP. Manual load balancing mode is usually used when the peer device does not support the LACP protocol.

Static LACP mode: In static LACP mode, both ends of the line use the LACP protocol to negotiate. This determines the link aggregation method for active interfaces and inactive interfaces. In this mode, create an Eth-Trunk. Adding an Eth-Trunk member interface needs to be done manually, and determining active interfaces and inactive interfaces is negotiated through the LACP protocol. Static LACP mode is also called M:N mode. This method can achieve the dual functions of link load sharing and redundancy backup at the same time. In the link aggregation group, M links are active, forwarding data and carrying load, while the other N links are inactive, not forwarding data. When one of the M links fails, the system will automatically select the highest priority link from the N backup links to take over the faulty link and start forwarding data.

The main difference between the static LACP mode and the manual load balancing mode is that the static LACP mode can have backup links, while in the manual load balancing mode, all member interfaces are in the forwarding state and share the load traffic unless the line fails.

Active vs. inactive interfaces

An interface that is active and responsible for forwarding data is called an active interface. Conversely, an interface that is in the inactive interface state and prohibits forwarding of data is called an inactive interface. Active interfaces and inactive interfaces generally do not require human intervention. In static LACP mode, the upper and lower limits for the number of active interfaces can be configured. Depending on the configured work mode, the division of roles is as follows;

In manual load balancing mode, under normal circumstances, all member interfaces are active interfaces unless link failures occur on these interfaces.

In static LACP mode, the interfaces corresponding to M links are active interfaces and are responsible for forwarding data, and the interfaces corresponding to N links are inactive interfaces and are responsible for redundant backup.

Link aggregation (manual aggregation mode)

Experimental topology diagram

image-20230306143725217

Experimental requirements

1. Create relevant VLANs on the switch; configure the interface connected to the PC as Access type and add it to the corresponding VLAN;
2. Configure the link between SW1 and SW2 as an aggregate link (Eth-trunk). The aggregated link works in manual load balancing mode.
mode, and configure the Eth-trunk as a Trunk-type interface because it needs to carry traffic of multiple VLANs;
3. After completing the configuration, PC1 and PC3 are required to be able to ping each other; PC2 and PC4 are required to be able to ping each other.

basic configuration

LSW1:
vlan 10 #Create vlan 10
int vl 10 #Open vlan 10 and write it into the vlan data table
ip add 192.168.10.254 24 #Configure vlanIP address
undo shutdown #Open vlan
vlan 20 #Create vlan 20
int vl 20 #Open vlan 20 and write it into the vlan data table
ip add 192.168.20.254 24 #Configure vlanIP address
undo shutdown #Open vlan
int eth0/0/1 enters interface eth0/0/1
port link-type access #Convert the interface to an access interface and allow a single vlan to pass
port default vlan 10 #Divide the interface into vlan 10
undo shutdown #Open the interface
int eth0/0/2 enters interface eth0/0/2
port link-type access #Convert the interface to an access interface and allow a single vlan to pass
port default vlan 20 #Divide the interface into vlan 20
undo shutdown #Open the interface
LSW2:
vlan 10 #Create vlan 10
int vl 10 #Open vlan 10 and write it into the vlan data table
ip add 192.168.10.254 24 #Configure vlanIP address
undo shutdown #Open vlan
vlan 20 #Create vlan 20
int vl 20 #Open vlan 20 and write it into the vlan data table
ip add 192.168.20.254 24 #Configure vlanIP address
undo shutdown #Open vlan
int eth0/0/1 enters interface eth0/0/1
port link-type access #Convert the interface to an access interface and allow a single vlan to pass
port default vlan 20 #Divide the interface into vlan 20
undo shutdown #Open the interface
int eth0/0/2 enters interface eth0/0/2
port link-type access #Convert the interface to an access interface and allow a single vlan to pass
port default vlan 10 #Divide the interface into vlan 10
undo shutdown #Open the interface

Experimental configuration

LSW1:
[LSW1]int Eth-Trunk 1 #Create link aggregation group 1
[LSW1-Eth-Trunk1]mode manual load-balance #The working mode is manual load balancing (the default is). Since the eth-trunk needs to carry the traffic of multiple vlans, it needs to be configured in trunk mode and vlan 10 and vlan are allowed at the same time. 20 traffic
[LSW1-Eth-Trunk1]port link-type trunk #Set the link aggregation mode to trunk link
[LSW1-Eth-Trunk1]port trunk allow-pass vlan 10 20 #Release vlan 10 and vlan 20
[LSW1-Eth-Trunk1]quit #Exit link aggregation configuration mode
[LSW1]int Ethernet0/0/3 #Enter interface eth0/0/3
[LSW1-Ethernet0/0/3]eth-trunk 1 #Add this interface to the link aggregation group of eth-trunk 1
[LSW1]int Ethernet0/0/4 #Enter interface eth0/0/4
[LSW1-Ethernet0/0/4]eth-trunk 1 #Add this interface to the link aggregation group of eth-trunk 1
LSW2:
[LSW2]int Eth-Trunk 1 #Create link aggregation group 1
[LSW2-Eth-Trunk1]mode manual load-balance #The working mode is manual load balancing (the default is). Since the eth-trunk needs to carry the traffic of multiple vlans, it needs to be configured in trunk mode and vlan 10 and vlan are allowed at the same time. 20 traffic
[LSW2-Eth-Trunk1]port link-type trunk #Set the link aggregation mode to trunk link
[LSW2-Eth-Trunk1]port trunk allow-pass vlan 10 20 #Release vlan 10 and vlan 20
[LSW2-Eth-Trunk1]quit #Exit link aggregation configuration mode
[LSW2]int Ethernet0/0/3 #Enter interface eth0/0/3
[LSW2-Ethernet0/0/3]eth-trunk 1 #Add this interface to the link aggregation group of eth-trunk 1
[LSW2]int Ethernet0/0/4 #Enter interface eth0/0/4
[LSW2-Ethernet0/0/4]eth-trunk 1 #Add this interface to the link aggregation group of eth-trunk 1

Understand the experiment

When an Eth-trunk works in manual load balancing mode, all member links will participate in data forwarding, that is, all member links are active links by default. Once we add GE0/0/23 and GE0/0/24 to the created aggregate link Eth-trunk 1, these two physical interfaces form a logical aggregate interface in the view of the switch, so for this aggregate interface The relevant configurations are all performed on interface eth-trunk 1, not on the two physical interfaces GE0/0/23 or GE0/0/24. Since the created aggregate interface Eth-trunk 1 needs to carry Layer 2 traffic of multiple VLANs, you need to change the link-type of this aggregate interface to trunk, and add two VLANs 10 and 20 to the list of allowed VLANs.

verify

LSW1:
display eth-trunk 1 #View the status of link aggregation

image-20230306145951541

LSW2:
display eth-trunk 1 #View the status of link aggregation

image-20230306150003602

We see that the aggregate link eth-trunk1 has two member links, namely eth0/0/3 and eth0/0/4, and the status is both UP. After completing the configuration, PC1 and PC4 should be able to ping directly; PC2 and PC3 should also be able to ping directly.

PC1pingPC4

ping 192.168.10.2

image-20230306150156004

PC2pingPC3

ping 192.168.20.2

image-20230306150308051

Guess you like

Origin blog.csdn.net/qq_54100121/article/details/133862374