Return of the Nim

Return of the Nim

Problem Description

Sherlock and Watson are playing the following modified version of Nim game:

  • There are n piles of stones denoted as ,,...,, and n is a prime number;
  • Sherlock always plays first, and Watson and he move in alternating turns. During each turn, the current player must perform either of the following two kinds of moves:
    1. Choose one pile and remove k(k >0) stones from it;
    2. Remove k stones from all piles, where 1≤kthe size of the smallest pile. This move becomes unavailable if any pile is empty.
  • Each player moves optimally, meaning they will not make a move that causes them to lose if there are still any better or winning moves.

Giving the initial situation of each game, you are required to figure out who will be the winner

Input

The first contains an integer, g, denoting the number of games. The 2×g subsequent lines describe each game over two lines:
1. The first line contains a prime integer, n, denoting the number of piles.
2. The second line contains n space-separated integers describing the respective values of ,,...,.

  • 1≤g≤15
  • 2≤n≤30, where n is a prime.
  • 1≤pilesi where 0≤in−1

Output

For each game, print the name of the winner on a new line (i.e., either "Sherlock" or "Watson")

Sample Input

2
3
2 3 2
2
2 1

Sample Output

Sherlock
Watson

Hint

Source

"Inspur Cup" Shandong Province 8th ACM College Student Programming Competition (Thanks to Qingdao University of Science and Technology)


The meaning of the title is to say that there are two people playing a game. There are two operations. One is to take k from all piles, but k cannot exceed the number of stones in the minimum pile, and the other is to take any number of stones from any pile. The number of stones, the question guarantees that the input heap number is a prime number.

We can be surprised to find that if the first operation is removed, it is a bare ground Nim, and if the second operation is removed, it is a bare ground Wizoff, so the solution to this problem is Nim + Wizoff, and Wizoff does not need to talk about it, only the number of heaps is 2 When it is Wyzoff, you can directly put it on the board, and then we consider Nim, that is, when n>=3, we will not talk about the second operation, which is bare Nim

code:

#include <bits/stdc++.h>
using namespace std;
int a[1000];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d",&a[i]);
        }
        if(n == 2){
            if(a[0] < a[1])
                swap(a[0],a[1]);
            if(floor((a[0] - a[1]) * ((sqrt(5.0)+1.0) / 2.0)) != a[1]){
                printf("Sherlock\n");
            }
            else{
                printf("Watson\n");
            }
        }
        else{
            int k = a[0];
            for(int i = 1; i < n; i++){
                k ^= a[i];
            }
            if(k == 0)
                printf("Watson\n");
            else
                printf("Sherlock\n");
        }
    }
    return 0;
}


Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325872370&siteId=291194637