Return of the Nim

Return of the Nim

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

Sherlock and Watson are playing the following modified version of Nim game:

  • There are n piles of stones denoted as ,,...,, and n is a prime number;
  • Sherlock always plays first, and Watson and he move in alternating turns. During each turn, the current player must perform either of the following two kinds of moves:
    1. Choose one pile and remove k(k >0) stones from it;
    2. Remove k stones from all piles, where 1≤kthe size of the smallest pile. This move becomes unavailable if any pile is empty.
  • Each player moves optimally, meaning they will not make a move that causes them to lose if there are still any better or winning moves.

Giving the initial situation of each game, you are required to figure out who will be the winner

Input

The first contains an integer, g, denoting the number of games. The 2×g subsequent lines describe each game over two lines:
1. The first line contains a prime integer, n, denoting the number of piles.
2. The second line contains n space-separated integers describing the respective values of ,,...,.

  • 1≤g≤15
  • 2≤n≤30, where n is a prime.
  • 1≤pilesi where 0≤in−1

Output

For each game, print the name of the winner on a new line (i.e., either "Sherlock" or "Watson")

Sample Input

2
3
2 3 2
2
2 1

Sample Output

Sherlock
Watson

When n=1, the first one will win. When n=2, the Wezhov game is played. Since n is a prime number, it is a nim game when n>2.

#include <iostream>
#include <cstdio>
#include <cmath>

using namespace std;

int t,n,a[35];

intmain()
{
    cin>>t;
    while(t--){
        cin>>n;
        int ant=0;
        for(int i=0;i<n;i++){
            cin>>a[i];
        }
        if(n==1)
            cout<<"Sherlock"<<endl;
        if(n>2){
            for(int i=0;i<n;i++){
                ant^=a[i];
            }
            if(ant==0)
                cout<<"Watson"<<endl;
            else
                cout<<"Sherlock"<<endl;
        }
        if(n==2){
            if(a[0]<a[1])
                swap(a[0],a[1]);
            int t=a[0]-a[1];
            int d=(int)((1+sqrt(5.0))*t/2.0);
            if(a[1]==d)
                cout<<"Watson"<<endl;
            else
                cout<<"Sherlock"<<endl;
        }
    }
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=324610468&siteId=291194637