HDU-3032--Nim or not Nim? (Game + SG play meter)

Problem Description
Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
 

Input
Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
 

Output
For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
 

Sample Input
 
  
232 2 323 3
 

Sample Output
 
  
AliceBob

Personally feel that this example can better understand the SG function table

 The meaning of the question: two players game, N piles of stones, you can choose to remove any number of stones from a certain pile, or you can choose to divide the pile into any two piles of things

Explanation on the code:

#include <stdio.h>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn = 1005;
int sg[maxn] , Hash[maxn] , F[maxn];
int N;
int fsg(int n)//The rule found by playing the table
{
	if(n % 4 == 3)return n+1;
	else if(n % 4 == 0)return n-1;
	else return n;
}
intmain()
{
	int t , res=0 ;
	while(~scanf("%d" , &t))//Multiple sets of input
	{
		while(t--)
		{
			
			scanf("%d" , &N);//N堆
			res = 0;
			memset(F , 0 , sizeof(F));
			for(int i = 0 ; i < N; i++)//Number of each heap
			{
				scanf("%d" , &F[i]);
			
			}
			for(int i = 0 ; i < N ; i++)
			{
				res ^= fsg(F[i]);//Each pile is XORed with each other
			}
		//	cout <<"res=" << res<<endl;
			if(res == 0)
			{
				printf("Bob\n");
			}
			else
			{
				printf("Alice\n");
			}
		}
	
	}
	
	return 0;
}

Attach the code for SG to play the meter:

void getsg()
{
	//nim game, choose any continuous number, so here sg[x]=x
	memset(sg , 0 , sizeof(sg));
	sg[0] = 0 ;
	sg[1] = 1 ;
	for(int i = 1 ; i <= maxn ; i++)//How many stones are in each pile, find the sg value of each number
	{
		memset(Hash , 0 , sizeof(Hash));
		for(int j = 1 ; j <= i ; j++)
		{
			Hash[sg[ij]] = 1;//Take any number
		}
		for(int j = 1 ; j < i ; j++)
		{
			Hash[sg[j] ^ sg[ij]] = 1; // Divide the stones into two piles
		}
		for(int j = 0 ; j <= maxn ; j++)
		{
			if(Hash[j] == 0)
			{
				sg[i]= j;
				break;
			}
		}
		cout <<i  <<":" <<sg[i] << endl;
	}	
}

Guess you like

Origin http://10.200.1.11:23101/article/api/json?id=326745153&siteId=291194637
Recommended