POJ - 1056 Immediate decodablity (dictionary tree data structure)

Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable:
A:01 B:10 C:0010 D:0000

but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from standard input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01
10
0010
0000
9
01
10
010
0000
9

Sample Output

Set 1 is immediately decodable
Set 2 is not immediately decodable

Problem solving ideas:

First, build a dictionary tree based on all the input strings, where it is assumed that the left node of each node represents '0' and the right node represents '1'.
The flag tag of the node where the last character of each string is located is set to 1.
Because, if the currently inserted string passes through a leaf node of the current tree, the prefix overlap occurs.
So after building the tree, traverse the whole tree, if there is a flag=1 of a non-leaf node, it means that there is a prefix coincidence.

Code:

#include <cstdio>
#include <iostream>
#include <string.h>
using namespace std;

typedef struct Tree{
    int flag;
    Tree *right;
    Tree *left;
}Tree , *Htree;

Tree *root;
char str[15];
void insert(char str[]){
    Tree *p = NULL;

    if(root == NULL){
        root = new Tree;
        root ->flag = 0;
        root ->left = NULL;
        root ->right = NULL;
    }

    p = root;

    int len = strlen(str);

    for(int i= 0 ; i < len ; i ++){
        if(str[i] == '0'){
            if(p ->left == NULL){
                p ->left = new Tree;
                p = p ->left;
                p ->flag = 0;
                p ->left = p ->right = NULL;
            }else{
                p = p ->left;
            }
        }else if(str[i] == '1'){
            if(p ->right == NULL){
                p ->right = new Tree;
                p = p ->right;
                p ->flag = 0;
                p ->left = p ->right = NULL;
            }else{
                p = p ->right;
            }
        }
    }
     p ->flag = 1;  //字符串的最后一个节点的 flag 置 1.

}

int decode(Tree *root){
    Tree *p;
    p = root;
    while(p != NULL){
        if(p ->flag == 1 && ( p ->left != NULL || p ->right != NULL) )   //非叶子节点的 flag =1 ,说明 这条路径是某个子串的前缀
            return 0;
        else
           return decode(p ->left)&&decode(p ->right);
    }
    return 1;
}
int main(){
    int i = 0;
    while( scanf("%s",str) != EOF ){
        if(str[0] != '9'){
            insert(str);
        }else{
            i ++;
            if(decode(root)){
                printf("Set %d is immediately decodable\n" , i );
            }else{
                printf("Set %d is not immediately decodable\n" , i );
            }
             root = NULL;  //很重要,不然会影响下一组测试数据
        }
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325858036&siteId=291194637