[POJ 3630] Phone List (static dictionary tree)

Phone List

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

The main idea of ​​the question: You enter T to represent the T group of samples, and n to represent n numbers. Then judge whether the number is the prefix of other numbers, if yes, output NO and if not, output YES. If you have 911 in your dictionary tree, you can't make calls like 911········.
This question can be done by comparing them in lexicographic order. But this only gives the code for the static dictionary tree. The dynamic dictionary tree cannot be used in this case where there may be 10,000 words, whether the memory exceeds the limit.

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

struct Trie  {  
    int count;  
    struct Trie *branch[10];  
}Memory[100005]; 

int num = 0;  

Trie *TrieNode()  {  
    Trie *p = &Memory[num++];  
    p->count = 0;  
    for(int k = 0; k < 10; k++){  
        p->branch[k] = NULL;  
    }  
    return p;  
}  

//将字符串number插入根为root的字典树  
void MakeTrie(Trie *&root, char *number){  
    int i = 0;  
    if(root == NULL){  
        root = TrieNode();  
    }  
    Trie *p = root;  
    while(number[i]){  
        if(!p->branch[number[i] - '0']){  
            p->branch[number[i] - '0'] = TrieNode();  
        }  
        p = p->branch[number[i] - '0'];  
        p->count++;  
        i++;  
    }  
}  

//判断字符串number是否为其他某字符串的前缀  
//如果是返回true,否则返回false  
bool IsPrefix(Trie *root, char *number){  
    int i = 0;  
    if(root == NULL){  
        return true;  
    }  
        Trie *p = root;  
    while(number[i]){  
        p = p->branch[number[i] - '0'];  
        if(p->count == 1)  
            return false;  
        i++;  
    }  
    return true;  
}  

int main(){  
    bool flag = true;  
    int j, n, t;  
    Trie *root = NULL;  
    char numbers[100005][11];  
    scanf("%d", &t);  
    while(t--){  
        scanf("%d", &n);  
        root = NULL;  
        for(j = 0; j < n; j++){  
            scanf("%s", numbers[j]);  
            MakeTrie(root, numbers[j]);  
        }  

        for(j = 0; j < n; j++){  
            if(IsPrefix(root, numbers[j])){  
                flag = false;  
                break;  
            }  
        }  
        if(flag){  
            printf("YES\n");  
        }  
        else{  
            printf("NO\n");  
        }  
        flag = true;  
        num = 0;  
    }  
    return 0;  
}  

Guess you like

Origin blog.csdn.net/thesprit/article/details/52084119