HDU 4496 D-CITY (union search)

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 5315    Accepted Submission(s): 1856


Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input
 
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 
Sample Output
 
  
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
 

Source

Analysis of Algorithms:

This problem requires deleting edges, and then finding the connected components of the graph after each deletion.  Then we can think about it. Suppose that deleting k edges is not actually adding mk edges, so we only need to insert each edge in reverse order and save the inserted edges separately. After that, the number of connected components of the new graph is in the array, and then the array can be output .

Code:

#include<cstdio>  
using namespace std;
#define N  10005
#define M  1100005
int x [M], y [M], fa [N + 100];
int sum[M];//Number of connected components when recording i
int findset(int x)
{
    return fa[x]==x?x:fa[x]=findset(fa[x]);
}
intmain()
{
    int n,m;
    while(scanf("%d%d",&n,&m)==2)
    {for(int i=1;i<=m;i++)
        scanf("%d%d",&x[i],&y[i]);
    for(int i=0;i<=n;i++)
        fa [i] = i;
        sum[m]=n;//Connected components when there is no edge
    for(int i=m;i>=1;i--)
    {
        int r1=findset(x[i]),r2=findset(y[i]);
        if(r1!=r2)//New connected component
        {
            fa [r1] = r2;
            sum[i-1]=sum[i]-1;
        }
        else
            sum[i-1]=sum[i];
    }
    for(int i=1;i<=m;i++)
        printf("%d\n",sum[i]);
    }
    return 0;
}

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325196875&siteId=291194637