Ubiquitous Religions(并查集)

 题目描述:学校调查学生中有多少个宗教群体,但是不好意思直接去问,所以他们想到一个间接问法,如果A同学信佛教,问B同学是不是和A同学是一样的宗教,然后依次类推,问C同学。最后得出有多少个宗教群体。当输入为0 0的时候,结束。

解题思路:典型并查集问题,直接将每一个同学创建一个父子集,如果遇到相同的,例如A与B,就将B改成A的父子集,依次类推,这里可以右变化也可以左变化,右变化就是A改成B的父子集。

错误分析:将初始值附为-1更简便。

 题目

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9

1 2

1 3

1 4

1 5

1 6

1 7

1 8

1 9

1 10

10 4

2 3

4 5

4 8

5 8

0 0

Sample Output

Case 1: 1

Case 2: 7

Hint

Huge input, scanf is recommended.

 AC代码

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int n,m,i,f[50050];
void init()
{
	int i;
	for(i=1;i<=n;i++)
		f[i]=-1;
	return ;
}
int getf(int v)
{
	if(f[v]==-1)
		return v;
	else
	{
		f[v]=getf(f[v]);
		return f[v];
	}
}
void merge(int u,int v)
{
	int t1,t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
		f[t2]=t1;
	return ;
}
int main()
{
	int x,y,t=1,sum;
	while(scanf("%d%d",&n,&m)!=EOF&&n)
	{
		init();
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			merge(x,y); 
		}
		sum=0;
		for(i=1;i<=n;i++)
		{
			if(f[i]==-1)
				sum++;
		}
		printf("Case %d: ", t);
		t++;
		printf("%d\n", sum);
	}
	return 0;
}

努力努力再努力

Guess you like

Origin blog.csdn.net/zz_xun/article/details/119995028