1104 Sum of Number Segments (20point(s))

1104 Sum of Number Segments (20point(s))

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10
​5
​​ . The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4
Sample Output:
5.00

At first I thought about making a watch, but there is still the complexity of o(n^2), obviously there is a timeout

#include<bits/stdc++.h>
using namespace std;
double sequence[100010];
double sum[100010];
int main(){
    
    
    int n;
    cin>>n;
    sum[0]=0.0;
    for(int i=1;i<=n;++i){
    
    
        cin>>sequence[i];
        sum[i]=sum[i-1]+sequence[i];
    }
    double ans=0;
    for(int i=1;i<=n;++i){
    
    
        for(int j=i;j<=n;++j)
            ans+=sum[j]-sum[i-1];
    }
    printf("%.2lf\n",ans);
}

Find the rules, there are basically pits in high-precision problems. After modifying the sample of this question, the double cannot be passed, and the double error becomes larger due to multiple accumulations.

#include<bits/stdc++.h>
using namespace std;
int main(){
    
    
    int n;
    scanf("%d",&n);
    long double num,ans=0.0;
    for(int i=0;i<n;++i){
    
    
        scanf("%llf",&num);
        ans+=num*(i+1)*(n-i);
    }
    printf("%.2llf\n",ans);
    return 0;
}

Guess you like

Origin blog.csdn.net/weixin_44970602/article/details/111649254