1144 The Missing Number (20 point(s))

Ideas:

Use set to save positive numbers greater than 0, and then get the minimum missing postive number.

1144 The Missing Number (20 point(s))

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

Example:

#include<iostream>
#include<set>
using namespace std;

int main()
{
    int N;
    cin >> N;
    set<int> s;
    for(int i = 0; i < N; i++) {
        int x;
        cin >> x;
        if(x > 0) s.insert(x);
    }
    int count = 1;
    if(s.size() > 0)
        for(auto x : s) {
            if(x != count) break;
            count++;
        }
    cout << count;
}

 

Guess you like

Origin blog.csdn.net/u012571715/article/details/114647680