1015 Reversible Primes (20point(s))

1015 Reversible Primes (20point(s))

A reversible prime in any number system is a prime whose “reverse” in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10
​5
​​ ) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:
The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:
For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

#include<bits/stdc++.h>
using namespace std;
int num[100];
bool isPrime(int n){
    
    
    if(n<=1) return false;
    for(int i=2;i*i<=n;++i)
        if(n%i==0) return false;
    return true;
}
int convert(int n,int radix){
    
    
    int i=0;
    do{
    
    
        num[i++]=n%radix;
        n/=radix;
    }while(n);
    int ans=0;
    for(int j=0;j<i;++j)
        ans=ans*radix+num[j];
    return ans;
}
int main(){
    
    
    int n,d;
    while(~scanf("%d",&n)&&n>0){
    
    
        scanf("%d",&d);
        if(isPrime(n)){
    
    
            if(isPrime(convert(n,d))){
    
    
                cout<<"Yes"<<endl;
                continue;
            }
        }
        cout<<"No"<<endl;
    }
    
}

Guess you like

Origin blog.csdn.net/weixin_44970602/article/details/111657972