Computer Network Experiment 6-Router configures RIP on two ISCOM switches supporting Layer 3 routing function

Router performs RIP configuration on two ISCOM switches supporting Layer 3 routing function

1. The purpose of the experiment

  • Master the use of Cisco Simulator
  • Master the configuration method of RIP dynamic routing of three-layer switch

2. Experimental significance

Through the use of RIP dynamic routing in the Cisco simulator, computers on different network segments can communicate with each other

Three, experimental equipment

  • Cisco Simulator

Four, experimental topology

Insert picture description here

Five, experimental steps and detailed configuration

  • According to the topology diagram, use the Cisco simulator to add 2 L3 switches and 4 PCs. The switches are connected through F0/24 ports. PC1 and PC2 are respectively connected to the VLAN6 and VLAN7 ports of SA, and PC3 and PC4 are respectively connected to SB VLAN8 and VLAN9 ports, and configure the IP address, subnet mask and gateway of all computers according to the topology diagram

  • The configuration commands are as follows:

    • Divide the vlan of the switch:

    • SA code:

    • Switch>enable
      Switch#config
      Configuring from terminal, memory, or network [terminal]? 
      Enter configuration commands, one per line. End with CNTL/Z.
      Switch(config)#hostname SA
      SA(config)#ip routing
      SA(config)#int ra fa 0/1-8
      SA(config-if-range)#swit mode access
      SA(config-if-range)#Swit access vlan 6
      % Access VLAN does not exist. Creating vlan 6
      SA(config-if-range)#exit
      SA(config)#int ra fa 0/9-16
      SA(config-if-range)#swit mode access
      SA(config-if-range)#Swit access vlan 7
      % Access VLAN does not exist. Creating vlan 7
      SA(config-if-range)#exit
      SA(config)#int ra fa 0/24
      SA(config-if-range)#swit mode access
      SA(config-if-range)#Swit access vlan 100
      % Access VLAN does not exist. Creating vlan 100
      
    • SB code:

    • Switch>enable
      Switch#config
      Configuring from terminal, memory, or network [terminal]? 
      Enter configuration commands, one per line. End with CNTL/Z.
      Switch(config)#hostname SB
      SB(config)#ip routing
      SB(config)#int ra fa 0/1-8
      SB(config-if-range)#swit mode access
      SB(config-if-range)#Swit access vlan 8
      % Access VLAN does not exist. Creating vlan 8
      SB(config-if-range)#exit
      SB(config)#int ra fa 0/9-16
      SB(config-if-range)#swit mode access
      SB(config-if-range)#Swit access vlan 9
      % Access VLAN does not exist. Creating vlan 9
      SB(config-if-range)#exit
      SB(config)#int ra fa 0/24
      SB(config-if-range)#swit mode access
      SB(config-if-range)#Swit access vlan 100
      % Access VLAN does not exist. Creating vlan 100
      
    • Configure the IP address of each vlan virtual port of the switch:

    • SA code:

    • SA>enable
      SA#config
      Configuring from terminal, memory, or network [terminal]? 
      Enter configuration commands, one per line. End with CNTL/Z.
      SA(config)#int vlan 6
      %LINK-5-CHANGED: Interface Vlan6, changed state to up
      %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan6, changed state 
      to up
      SA(config-if)#ip address 172.16.6.1 255.255.255.0
      SA(config-if)#no shut
      SA(config-if)#exit
      SA(config)#int vlan 7
      %LINK-5-CHANGED: Interface Vlan7, changed state to up
      %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan7, changed state 
      to up
      SA(config-if)#ip address 172.16.7.1 255.255.255.0
      SA(config-if)#no shut
      SA(config-if)#exit
      SA(config)#int vlan 100
      %LINK-5-CHANGED: Interface Vlan100, changed state to up
      %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed 
      state to up
      SA(config-if)#ip address 172.16.100.1 255.255.255.0
      SA(config-if)#no shut
      
    • SB code:

    • SB>enable
      SB#config
      Configuring from terminal, memory, or network [terminal]? 
      Enter configuration commands, one per line. End with CNTL/Z.
      SB(config)#int vlan 8
      %LINK-5-CHANGED: Interface Vlan8, changed state to up
      %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan8, changed state 
      to up
      SB(config-if)#ip address 172.16.8.1 255.255.255.0
      SB(config-if)#no shut 
      SB(config-if)#exit
      SB(config)#int vlan 9
      %LINK-5-CHANGED: Interface Vlan9, changed state to up
      %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan9, changed state 
      to up
      SB(config-if)#ip address 172.16.9.1 255.255.255.0
      SB(config-if)#no shut 
      SB(config-if)#exit
      SB(config)#int vlan 100
      %LINK-5-CHANGED: Interface Vlan100, changed state to up
      %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed 
      state to up
      SB(config-if)#ip address 172.16.100.2 255.255.255.0
      SB(config-if)#no shut
      SB(config-if)#exit
      
    • Start the RIP protocol to realize the communication between the two switches:

    • SA code:

    • SA>enable
      SA#config
      Configuring from terminal, memory, or network [terminal]? 
      Enter configuration commands, one per line. End with CNTL/Z.
      SA(config)#router rip
      SA(config-router)#version 2
      SA(config-router)#network 172.16.6.0
      SA(config-router)#network 172.16.7.0
      SA(config-router)#network 172.16.100.0
      
    • SB code:

    • SB>enable
      SB#config
      Configuring from terminal, memory, or network [terminal]? 
      Enter configuration commands, one per line. End with CNTL/Z.
      SB(config)#router rip
      SB(config-router)#version 2
      SB(config-router)#network 172.16.8.0
      SB(config-router)#network 172.16.9.0
      SB(config-router)#network 172.16.100.0
      
    • After completing the above configuration, test the connectivity between the PCs

6. Experimental results and screenshots

Topology configuration:
Insert picture description here

Divide the vlan of the switch:

TO:
Insert picture description here

SB:
Insert picture description here

Configure the IP address of each vlan virtual port of the switch:

TO:
Insert picture description here

SB:
Insert picture description here

Start the RIP protocol to realize the communication between the two switches:

TO:
Insert picture description here

SB:
Insert picture description here

The communication between PCs after starting the RIP protocol

PC1 and SB can communicate:
Insert picture description here

PC1 and PC3 can communicate:
Insert picture description here

PC1 and PC4 can communicate:
Insert picture description here

Guess you like

Origin blog.csdn.net/kelxLZ/article/details/111240535