Network-IS-IS: Experimental operation

ISIS—Experimental Operation

Experimental topology + configuration ideas + IP allocation + all experimental codes

Topology diagram, topology configuration ideas, topology IP address allocation

Insert picture description here

Topology code diagram:

Insert picture description here

Topology code block

AR1 code block

sysname AR1 #Change the device name
interface LoopBack0 #Enter loopback port 0
ip address 1.1.1.1 255.255.255.255 #Configure IP
isis enable 1 #Enable ISIS
interface GigabitEthernet0/0/0
ip address 192.168.1.254 255.255.255.0
isis enable 1
interface GigabitEthernet0/ 0/1
ip address 10.0.11.1 255.255.255.0
isis enable 1
isis 1
network-entity 49.0001.0000.0000.0001.00 #Configure NASP address

AR2 code block

sysname AR2
interface LoopBack0
ip address 2.2.2.2 255.255.255.255
isis enable 1
interface GigabitEthernet0/0/0
ip address 10.0.25.2 255.255.255.0
isis enable 1
interface GigabitEthernet0/0/1
ip address 192.168.2.254 255.255.255.0
isis enable 1
isis 1
network-entity 49.0001.0000.0000.0002.00

SW1 code block

sysname SW1
vlan batch 11 to 12 #Create VLAN 11 to 12
interface LoopBack0
ip address 11.11.11.11 255.255.255.255
isis enable 1
interface GigabitEthernet0/0/1
port link-type access #The interface link type is set to ACCESS
port default vlan 11 # Interface configuration VLAN is 11
interface Vlanif11 #Enter VLANIF11
ip address 10.0.11.11 255.255.255.0
isis enable 1
interface GigabitEthernet0/0/2
port link-type access
port default vlan 12
interface Vlanif12
ip address 10.0.12.1 255.255.255.0
isis enable 1
isis 1
network-entity 49.0001.0000.0000.0011.00

SW2 code block

sysname SW2
vlan batch 12 23 #创建VLAN 12和23
interface LoopBack0
ip address 22.22.22.22 255.255.255.255
isis enable 1
interface GigabitEthernet0/0/1
port link-type access
port default vlan 12
interface Vlanif12
ip address 10.0.12.2 255.255.255.0
isis enable 1
interface GigabitEthernet0/0/2
port link-type access
port default vlan 23
interface Vlanif23
ip address 10.0.23.2 255.255.255.0
isis enable 1
isis 1
network-entity 49.0001.0000.0000.0022.00

SW3 code block

sysname SW3
vlan batch 23 34
interface LoopBack0
ip address 33.33.33.33 255.255.255.255
isis enable 1
interface GigabitEthernet0/0/1
port link-type access
port default vlan 23
interface Vlanif23
ip address 10.0.23.3 255.255.255.0
isis enable 1
interface GigabitEthernet0/0/2
port link-type access
port default vlan 34
interface Vlanif34
ip address 10.0.34.3 255.255.255.0
isis enable 1
isis 1
is-level level-2 #指定设备角色为L2
network-entity 49.0001.0000.0000.0033.00

SW4 code block

sysname SW4
vlan batch 34 45
interface LoopBack0
ip address 44.44.44.44 255.255.255.255
isis enable 1
interface GigabitEthernet0/0/1
port link-type access
port default vlan 34
interface Vlanif34
ip address 10.0.34.4 255.255.255.0
isis enable 1
interface GigabitEthernet0/0/2
port link-type access
port default vlan 45
interface Vlanif45
ip address 10.0.45.4 255.255.255.0
isis enable 1
isis 1
network-entity 49.0001.0000.0000.0044.00

SW5 code block

sysname SW5
vlan batch 25 45
interface LoopBack0
ip address 55.55.55.55 255.255.255.255
isis enable 1
interface GigabitEthernet0/0/1
port link-type access
port default vlan 45
interface Vlanif45
ip address 10.0.45.5 255.255.255.0
isis enable 1
interface GigabitEthernet0/0/2
port link-type access
port default vlan 25
interface Vlanif25
ip address 10.0.25.5 255.255.255.0
isis enable 1
isis 1
network-entity 49.0001.0000.0000.0055.00

The experimental operation of ISIS is here. The configuration of ISIS is much simpler and faster than the OSPF protocol. If you don’t understand anything, you can refer to my network-IS-IS: theoretical knowledge.

Guess you like

Origin blog.csdn.net/qq_49296785/article/details/108070602