POJ-1251 Jungle Roads (minimum spanning tree prime)

Insert picture description here
The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input
The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.
Output
The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
Sample Output
216
30
Analysis of question meaning: This question is actually not too difficult. It may take some effort to read the question. First enter an integer n to indicate the number of villages, and each of the next n-1 lines The meaning of the line is as follows: A 2 B 12 I 25 means that there are two villages connected to A, namely B and I. The distance between B and A is 12, and the distance between I and A is 25.
Problem-solving idea: Seek the minimum cost in the minimum spanning tree. The array of this problem cannot be opened too large, otherwise it will run incorrectly after submitting on the POJ. In addition, each letter and the space after it should not be entered separately, or it will time out , Although this question is not difficult to think about, but it requires more details, and I have been wrong many times before the
AC code of AC is as follows:

#include<stdio.h>
#include<string.h>
int book[900],dis[900];
int e[30][30];
int inf=999999999;
char str1[5],str2[5];
int main(){
    
    
	int i,j,u,v,min,n,m,t1,t2,t3,sum;
	char a,b;
	while(scanf("%d",&n),n!=0){
    
    
		sum=0;
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
			for(j=1;j<=n;j++)
				if(i==j) e[i][j]=0;
				else e[i][j]=inf;
		for(i=1;i<n;i++){
    
    
			scanf("%s%d",str1,&m);//将每个字母和它后面的空格当成一个字符串来输入,分开输入超时
			t1=str1[0]-'A'+1;//将每个字符从1到26编号
			for(j=1;j<=m;j++){
    
    
				scanf("%s%d",&str2,&t3);
				t2=str2[0]-'A'+1;
				e[t1][t2]=e[t2][t1]=t3;//道路是双向的
			}
		}
		for(i=1;i<=n;i++)
			dis[i]=e[1][i];
		book[1]=1;
		for(i=1;i<n;i++){
    
    
			min=inf;
			for(j=1;j<=n;j++){
    
    
				if(book[j]==0&&dis[j]<=min){
    
    
					min=dis[j];
					u=j;
				}
			}
			book[u]=1;
			sum+=dis[u];//计算最小花费
			for(v=1;v<=n;v++){
    
    
				if(e[u][v]<inf){
    
    
					if(book[v]==0&&dis[v]>e[u][v])
						dis[v]=e[u][v];
				}
			}
		} 
		printf("%d\n",sum);
	} 
	return 0;
} 

Guess you like

Origin blog.csdn.net/weixin_44313771/article/details/107391234