POJ 1251 Jungle Roads (template title)

Jungle Roads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27279   Accepted: 12839

Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

Input

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

Output

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

Ideas: the character is converted into an integer, and then apply the template

#include <iostream>
#include <algorithm>
#include <string.h>
#include <cstdio>
#include <string>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
//#include <unordered_map>
#define Fbo friend bool operator < (node a, node b)
#define mem(a, b) memset(a, b, sizeof(a))
#define FOR(a, b, c) for (int a = b; a <= c; a++)
#define RFOR(a, b, c) for (int a = b; a >= c; a--)
#define off ios::sync_with_stdio(0)
#define sc(a) scanf("%d",&a) 
bool check1(int a) { return (a & (a - 1)) == 0 ? true : false; }

STD namespace the using; 
typedef pair <int, int> PII; 
typedef Long Long LL; 
const int = INF 0x3f3f3f3f; 
const int + 1E9 = MOD. 7; 
const int MAXN = 1005; 
const Double PI = ACOS (-1.0); 
const Double . 8 = 1E-EPS; 

int VIS [1010]; // for 0 and 1 flag indicating whether this point is selected through the 
int graph [1010] [1010] ; // adjacency matrix for storing map information 
int dis [1010 ]; // record the distance from any point to the nearest point 
int n-, m, Minn, minid, SUM; 
int Prim () 
{ 
    MEM (VIS, 0); 
    SUM = 0; 
    for (int I = 0; I <n- ; I ++) { 
        DIS [I] = Graph [0] [I]; 
        // << COUT DIS [I] << "-"; 
    } 
   // COUT << endl; 
    VIS [0] =. 1; // select the starting point  
    for (int i = 1; i <n;i++)
    {
        minn = INF; // store to find the smallest edge 
        minid = 0; // store minimum edge node number 
        for (J = int. 1; J <n-; J ++) 
        { 
            IF (VIS [J] && DIS [J] <! minimum edge node minn) // iterate over the dis 
            { 
                Minn dis = [J]; 
                minid = J; 
            } 
        } 
        SUM + = Minn; 
        VIS [minid] =. 1; // represents found 
    // ⑤ find the smallest after updating the node array DIS 
        for (int. 1 = J; J <n-; J ++) // update the minimum distance after the insertion of a new point 
        { 
            iF // edge when added, updated DIS (VIS [J]!) 
                DIS [J] min = (DIS [J], Graph [minid] [J]); 
        } 
    } 
    return SUM; 
} 
int main () {
    while (~scanf("%d", &n), n) {
        mem(graph, INF);
        for (int i = 0; i < n - 1; i++) {
            char u;
            int t;
            scanf(" %c %d", &u, &t);
            while (t--) {
                char v;//景区
                int w;//边权值
                scanf(" %c %d", &v, &w);
                graph[i][v - 'A'] = graph[v - 'A'][i] = w;//建图
            }
        }
        printf("%d\n", prim());
    }
    return 0;
}

  

Guess you like

Origin www.cnblogs.com/AlexLINS/p/12657472.html