prime minimum spanning tree

Truck History
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 31871   Accepted: 12427

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o ,t d ) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaaa
0

Sample Output

The highest possible quality is 1/3.
Title:
give you an n;
n strings of length 7;
Each string represents a node, each node has an edge to all other points, and the edge length is the number of different characters in the same position of the two node strings;
Requires you to generate the shortest path sum of edge weights.
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define N 2010
#define M 10

char str[N][M];//put string
int n;//Number of nodes
int vis[N],dst[N],map[N][N]; //vis accesses the array, dst puts the minimum distance from each point to MST

int finddst(int i,int j)//Find the number of columns with different characters in two strings
{
	int num=0,k;
	
	for (k=0;k<7;k++)
	{
		if(str[i][k]!=str[j][k])
		{
			num++;
		}
	}
	return num;
}

void init()
{
	int j,i;
	
	memset(vis,0,sizeof(vis));//Access the initial array
	for (i=0;i<n;i++)//initialization graph
	{
		for (j=0;j<n;j++)
		{
			if (i==j)
			{
				map[i][j]=0;
			}
			
			map[i][j]=finddst(i,j);			
		}
	}
}

void prime()
{
	int i,j,min,point,ans=0;
	
	vis[0]=1;//0 point is put into MST
	for (i=0;i<n;i++)//dst初始化
	{
		dst[i]=map[i][0];
	}
	
	for (i=1;i<n;i++)
	{
		min = N;
		for (j=0;j<n;j++)//Find the closest point to MST
		{
			if (vis[j]==0&&min>dst[j])
			{
				min = dst [j];
				point=j;
			}
		}
		
		if (min==N)//Disconnected
		{
			break;
		}
		
		vis[point]=1;//Put the point into MST
		ans=ans+dst[period];
		
		for (j=0;j<n;j++)//Update the minimum distance from each point to MST
		{
			if (vis[j]==0&&dst[j]>map[point][j])
			{
				dst[j]=map[point][j];
			}
		}
	}
	
	printf("The highest possible quality is 1/%d.\n",ans);
}

intmain()
{
	int i,j;
	
	while (scanf("%d",&n)&&n)
	{
		for (i=0;i<n;i++)
		{
			scanf("%s",&str[i]);
		}
		
		init();
		prime();
	}
	
	return 0;
}

 

Guess you like

Origin http://43.154.161.224:23101/article/api/json?id=325292210&siteId=291194637